Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just purchased a new router (Buffalo WZR-HP-G300NH) and setup our router in a new location. I'm running the stock firmware 1.72.

Between my PC and the router there are several walls and a ceiling. The router is sitting in the basement which is mostly directly underneath the rest of the house. The router sits close to the basement ceiling--the floor of the rest of the house. The router appears to give out a fairly strong signal, however, the Internet tends to cut out from time-to-time. I wanted to determine if it was our new router or the ISP that was at fault, to do this, I ran a ping -t to see if I'm getting a steady response from the router.

Reply from <routerIPAddress>: bytes=32 time=1ms TTL=64
Reply from <routerIPAddress>: bytes=32 time<1ms TTL=64
Reply from <routerIPAddress>: bytes=32 time<1ms TTL=64
Reply from <routerIPAddress>: bytes=32 time=124ms TTL=64
Reply from <routerIPAddress>: bytes=32 time=1ms TTL=64
Reply from <routerIPAddress>: bytes=32 time=31ms TTL=64
Reply from <routerIPAddress>: bytes=32 time=60ms TTL=64
Reply from <routerIPAddress>: bytes=32 time=3ms TTL=64
Reply from <routerIPAddress>: bytes=32 time=165ms TTL=64
Request timed out.
Reply from <routerIPAddress>: bytes=32 time=106ms TTL=64
Reply from <routerIPAddress>: bytes=32 time=14ms TTL=64
Reply from <routerIPAddress>: bytes=32 time=6ms TTL=64
Reply from <routerIPAddress>: bytes=32 time=3ms TTL=64
Reply from <routerIPAddress>: bytes=32 time<1ms TTL=64
Reply from <routerIPAddress>: bytes=32 time<1ms TTL=64
Reply from <routerIPAddress>: bytes=32 time=1ms TTL=64
Reply from <routerIPAddress>: bytes=32 time=11ms TTL=64
Reply from <routerIPAddress>: bytes=32 time=2ms TTL=64
Reply from <routerIPAddress>: bytes=32 time=8ms TTL=64
Reply from <routerIPAddress>: bytes=32 time=5ms TTL=64
Reply from <routerIPAddress>: bytes=32 time=13ms TTL=64
Request timed out.
Reply from <routerIPAddress>: bytes=32 time=906ms TTL=64
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Reply from <routerIPAddress>: bytes=32 time=371ms TTL=64
Request timed out.
Reply from <routerIPAddress>: bytes=32 time=260ms TTL=64
Request timed out.
Reply from <routerIPAddress>: bytes=32 time=610ms TTL=64
Request timed out.
Reply from <routerIPAddress>: bytes=32 time=206ms TTL=64
Reply from <routerIPAddress>: bytes=32 time<1ms TTL=64
Request timed out.
Request timed out.
Reply from <routerIPAddress>: bytes=32 time=149ms TTL=64
Reply from <routerIPAddress>: bytes=32 time=531ms TTL=64
Reply from <routerIPAddress>: bytes=32 time=8ms TTL=64
Request timed out.
Reply from <routerIPAddress>: bytes=32 time<1ms TTL=64
Reply from <routerIPAddress>: bytes=32 time<1ms TTL=64
Reply from <routerIPAddress>: bytes=32 time<1ms TTL=64
Reply from <routerIPAddress>: bytes=32 time=1ms TTL=64
Reply from <routerIPAddress>: bytes=32 time<1ms TTL=64
Reply from <routerIPAddress>: bytes=32 time=1ms TTL=64
Reply from <routerIPAddress>: bytes=32 time<1ms TTL=64
Reply from <routerIPAddress>: bytes=32 time<1ms TTL=64

Other related symptom -- our phones randomly leave our WiFi for the 3G network despite the 3 bars of wifi.

What could cause such a sudden degradation of quality? Could the router placement be bad? Should I find a better place for the router? Is the router itself faulty?

share|improve this question
add comment

2 Answers 2

Firstly ping time.

Variations in ping time tell you nothing. If a host receives a ping packet there is nothing to say it should respond as fast as possible. Therefore variations in ping time are both normal and to be expected.

Onto your real problem. You're getting some periods when packets are getting corrupted. With Wifi you've got a shared collision domain. If you and your neighbour are both using the same channel, and your neighbour downloads a huge file, you might find you're suffering from collisions too. Also if you've got 25 neighbours and they've all got wifi, then you might find that you're always getting problems.

Most routers seem to default to channel 6. Try switching to 1 or 11 instead. One of those channels will be the quietest in your neighbourhood and give the best access.

Your problem doesn't seem to be due to the placement of the router, if it was, then you'd probably see bad times all the time, and get bad signal quality.

share|improve this answer
    
Better yet if your router supports variable channel you can let it determine the best channel based on environment. Regardless, good answer gorilla. Spot on. –  Chris Oct 11 '10 at 0:22
    
Actually I did set the router to auto scan channel. It chose channel 1 while all my neighbors are on channel 6. –  Doug T. Oct 11 '10 at 0:27
    
My experience is that auto-channel is pretty useless. It's usually on by default, yet wireless routers with it on select a channel where there is interference. It's best to check yourself, using NetStumbler (pre-Vista) or InSIDDer. NetStumbler has the advantage of showing signal-to-noise ratios. –  paradroid Oct 11 '10 at 1:42
add comment
up vote 1 down vote accepted

Ok yes it was the placement. Probably should have tried that before asking the question.

I placed the router up in between the basement ceiling and 1st floor floor between two floor joists. There's a reflective metal vent in this area too. According to this link this isn't a great placement:

Your router should be out in the open; don’t put it under your desk, in a drawer, or behind a metal file cabinet.

I had placed the router here because the RSSI here was the highest as measured by inSSIDer. I guess RSSI is measuring raw power, not actual signal quality. Maybe somebody can shed some light as to why raw power (RSSI) does not necessarily equate to good signal quality.

Placing the router in a more open location gets rid of the symptoms and I get slightly variable, but constantly sub 10ms ping times.

A secondary factor has turned out to be the router's auto-channel setting. Occasionally the router will do a scan on the channels and begin switching channels rapidly. This may cause a disconnect or failure to ping. To fix set the channel number to a static channel. See this knowledge base article for more info.

http://www.buffalotech.com/knowledgebase/users/kb.php?id=10044&category_id=9&sid2=

share|improve this answer
    
If you have an XP laptop, try using NetStumbler, as it can shows SNR values. –  paradroid Oct 11 '10 at 1:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.