Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Firefox. XP3.

My friend loaded some personally recorded mp3 files for me to download from Dropbox. However, when I follow the link I only get a Quicktime media player in a browser window. How can I download the actual files themselves?

The link here in related questions refers to Macs. I also did a google search to no avail.

Thanks for your help.

share|improve this question
add comment

6 Answers 6

up vote 1 down vote accepted

In Firefox go to Tools/Options Applications Tab, search down the list until you find mp3 (or music files, or quicktime file, it depends on what program is associated with mp3s) and change the option to always ask, that way Firefox should ask you if you want to download the mp3 file.

share|improve this answer
    
This seems so promising. I followed your instructions and changed ALL quicktime-enabled choices to "Ask". It hasn't worked, the song still just plays. –  Xavierjazz Oct 11 '10 at 15:16
    
HAPPY, HAPPY. Your advice lead me to try the save options instead of "Ask". It now works. Thanks. +1 and accept. Regards, –  Xavierjazz Oct 11 '10 at 15:23
    
Glad you got it working. –  Jane T Oct 11 '10 at 15:53
add comment

Add ?dl to the end of the link :)

share|improve this answer
    
Thank you @emtunc. I now have a workable solution so I shall not need to try yours. I cannot up-vote your answer as I do not have enough knowledge to know if it is accurate. I hope it will be upvoted by a couple of others so that then I can also support your contribution. Regards, –  Xavierjazz Oct 11 '10 at 20:50
    
This is the best way to ensure your link downloads by default. See: dropbox.com/help/201/en –  Malcolm Smith Jan 15 '13 at 21:35
add comment

What you're trying to do is built right into DropBox. Click on the little downwards-facing arrow next to file, then click on "download now". It should ask you to save the file to the disk, and not open it in the browser.

alt text

share|improve this answer
    
I don't have access to her dropbox options. The addresses are in an email she sent me and are in her "Public" folder. –  Xavierjazz Oct 11 '10 at 6:53
    
Ohhhh... That sort of information can be useful, and while it is sort of implied in your question, would have been good to explicitly state. With the page open in firefox, you should be able to click "File" -> "Save As". If that doesn't work, could you post whatever isn't working about that method? –  nhinkle Oct 11 '10 at 7:14
add comment

Two things to try:

  1. Go back to the link your friend sent. See if you can right click on it and "Save target as..." or "Save link as..."
  2. Try "Save Page As" in the "File menu" from the window that has the media player in it.
share|improve this answer
    
1. Doesn't work. 2. Doesn't work. –  Xavierjazz Oct 11 '10 at 6:34
1  
Could you be a little more specific about what happens when "it doesn't work"? That's the proper way to do it and is how it should work, so it would be useful to know what happens. –  nhinkle Oct 11 '10 at 6:47
    
I have the links in my email. When I right click on one of them I only get: Copy, select all and View scource as options. When I launch the link, a Quicktime browser window comes up. The only choice there is: About Quicktime Plugin. Thanks. –  Xavierjazz Oct 11 '10 at 14:52
add comment

Ctrl-click (or two-finger-tap) on the link to the file and choose "Download Linked File".

share|improve this answer
    
Doesn't work. –  Xavierjazz Oct 11 '10 at 6:33
add comment

I often use this little trick to download links.

  1. Copy and paste the following code in a new HTML file, say download.html
  2. Open it with browser
  3. Right click the link > Save Link As (or equivalent)

<html>
<body>
<a href="http://paste.your/link/here">link</a>
</body>
</html>
share|improve this answer
    
I'm a bit unsure about using scripts so I didn't try this. I wasn't able to get a "Save as" dialogue when right-clicking on the link. However I was able to solve the problem because of other advice here. Thanks anyway. –  Xavierjazz Oct 11 '10 at 15:26
    
@Xavierjazz, good to hear that you solved the problem :) –  wilson Oct 12 '10 at 1:48
    
@Xavierjazz, for IE, it should be "Save Target As". for Firefox, it should be "Save Link As" –  wilson Oct 12 '10 at 3:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.