Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On a Mac, if you hold shift and press the backspace key, it performs a forward-delete (the same as pressing "delete" on a non-Mac keyboard). Is there any way to change this to just be a regular backspace?

share|improve this question
2  
Just to be clear, "don't hold shift" isn't really what I'm looking for... –  nickf Oct 11 '10 at 9:51
    
I'm dying of curiosity, why would you want this? –  Nifle Oct 11 '10 at 9:55
    
when programming. Say I'm typing Entity.DELETED but I get to Entity.DELTE.. to fix the mistake, you have to release shift and then press it again afterwards. I know it sounds silly, but it's a real PITA when shift-backspace deletes the line-ending and then starts deleting other things you didn't want. –  nickf Oct 11 '10 at 10:07
1  
What keyboard are you using? On my MacBook to get a forward delete I need to hold Fn-delete. That is, typically it is ⌫ but with Fn I get ⌦. Are you saying that ⇧⌫ gets you ⌦? –  fideli Oct 11 '10 at 14:26
1  
What keyboard layout (in System Preferences, Language & Text, Input Sources) is this? It's not British, US, US Extended or US International (or German for that matter). All of those require fn to be pressed for a forward-delete. –  Daniel Beck Oct 11 '10 at 20:43

2 Answers 2

up vote 1 down vote accepted

Ok I'm stupid.

I have DoubleCommand installed, and I, for some reason, enabled the "shift+delete acts as forward delete" command. Apologies.

share|improve this answer
    
You should accept your own answer, so the question doesn't show up as unanswered. –  Daniel Beck Oct 25 '10 at 16:14

You can try to change your keyboard layout in System Preferences, Language and Text, Input Sources. The Keyboard Viewer, accessible from the menubar item you can enable in that same preference pane enables you to preview keyboard layouts you temporarily select via the same menubar item. You just need to check them in the list to enable them.

You can also use Ukelele to create your own custom keyboard layout.

This can also be a custom command in your programming editor. IDEs often create additional shortcuts that alleviate the sometimes painfully lame input/shortcut options integrated in the system. Check TextEdit.app if it behaves the same, only then is it layout-related.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.