Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm currently having some bother with a dual boot box running Windows XP and Fedora. Whenever I reboot into the other operating system, the time is an hour out - when going from Fedora to Windows, it's an hour behind; when moving from Windows to Fedora, it's an hour fast. Both systems are set to the correct time zone, and correctly update from network time servers, although Windows will only do this automatically once a week.

What I'm guessing is happening is that Windows is saving the time to the system clock in local time, wheras Linux is saving it in GMT (or with/without daylight saving offset added - effectively the same thing here in Scotland at the moment). Is there any way to get round this? It causes particular issues when booting into Windows and then back to Fedora, as LDAP authentication then fails (it thinks something fishy is going on when the request apparently takes an hour to travel between client and server). Can Fedora be set to emulate Windows' behaviour? Can Windows be set to accept Fedora's behaviour?

share|improve this question

3 Answers 3

up vote 2 down vote accepted

When dual booting linux and windows, make sure the motherboard clock is set to "local", or at least that both agree on the format. In gentoo you set it in /etc/conf.d/clock, variable CLOCK="local".
On fedora I don't know where you do it.

Probably you should set UTC=false in /etc/sysconfig/clock.

share|improve this answer
    
Setting UTC=false in /etc/sysconfig/clock sorted it out. Thanks! –  Scott Oct 11 '10 at 13:22

I think I've had this before myself in the past with a virtual PC and I got round it by having a program run at start up (or capable of being run on demand) which would set the machine time to the correct time.

Maybe something like this although I haven't tried it myself:

Atomic Clock Sync

(Although you would obviously need something like this on the Linux boot also)

share|improve this answer

Both systems are set to the correct time zone

This is probably a DST issue - do both systems have the latest DST patches? In particular for Windows, check that "Automatically adjust clock for daylight savings" is enabled under timezone.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.