Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I created a folder structure as root and now need to transfer ownership to an ordinary user.

This question is linked to this one -

I have a folder /srv/app-share that needs to be visible/writeable to user1

I tried (as root):

root@server [/]# chown -R user1:user1 /srv/

But that did not work.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

What messages did you get, any errors? Did you try without the last slash in /srv/ so that it specifically indicates the directory itself?

As simple test confirms it works my side, however I did not specify a group:

root@server [/]# chown -R user1: /srv/

Perhaps there is no group called 'user1' in your case? run groups | grep user1 and see if you have that user group.

share|improve this answer
Interesting - you were right that there is no group as user1, but even using your command, as user1, I'm still not able to see/navigate to /srv – siliconpi Oct 11 '10 at 12:43
Im confused, you can't navigate to /srv? Does it not exist then? I thought you can't set the owner. – invert Oct 11 '10 at 13:57
what does ls -a /srv/ show you? I get an empty dir . .. – invert Oct 11 '10 at 13:58
It was created by root, and the root can navigate to it. But after chown-ing it, it's not visible for user1 (/srv) – siliconpi Oct 11 '10 at 15:00
umm - just for clarification, it wasnt visible before to user1 either... – siliconpi Oct 11 '10 at 15:28

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.