Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After sharing my wwwroot folder to the rest of my homegroup, I'm now getting the following error on my website:

Server Error

401 - Unauthorized: Access is denied due to invalid credentials. You do not have permission to view this directory or page using the credentials that you supplied.

My guess is that the folder permissions were mangled when I shared the wwwroot folder. I tried unsharing the folder and restarting IIS7 but I'm still getting the error. Does anyone know the default permissions needed for the wwwroot folder? IIS7 is configured with default settings (i.e., I haven't changed any IIS7 settings).

Any help is greatly appreciated.

Already Tried:

  • Restarting IIS7
  • Turning off and then back on anonymous authentication
  • Unsharing the wwwroot folder
share|improve this question
    
Have you granted permissions for the ASP.net account to access that folder ? –  Sathya Oct 11 '10 at 15:41
    
The IUSRS group has access to the folder. –  Brian Hasden Oct 11 '10 at 15:43
add comment

2 Answers

up vote 6 down vote accepted

In order to reset the wwwroot permissions I went to another box and copied all the settings to the web server having issues.

Here's the steps to return to the default permissions for the wwwroot folder:

  1. right-click on the wwwroot folder and click Properties
  2. go to the Security tab and click the Advanced button
  3. click the "Change Permissions..." button and make check the "Include inheritable permissions from this object's parent" checkbox
  4. remove all permission entries where the "Inherited From" column has a value of "<not inherited>"
  5. click Apply and verify that the following 5 permission entries are being inherited from the "C:\inetpub\" directory:
    • TrustedInstaller - Full control
    • SYSTEM - Full control
    • Administrators - Full control
    • Users - Read & execute
    • CREATOR OWNER - Special

Once those permissions are verified, click the Add button and enter "IIS_IUSRS" for the object name and click OK. Select "Traverse folder / execute file", "List folder / read data", "Read attributes", "Read extended attributes", and "Read permissions" from the permissions list and click OK.

The wwwroot folder should now be set back to the out of the box permissions that come with IIS7.

This fixed the mentioned 401 Access Denied error I was encountering.

share|improve this answer
add comment

I ran into this same issue. Rather than re-create all permissions though, just had to re-add WEBSERVER\Users with read permissions - it seems that sharing the folder maybe removed that one?

share|improve this answer
    
I had the same issue. Any idea why it gets removed when sharing a folder? –  MrVimes May 22 '13 at 10:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.