Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a bunch of folders on my hardrive that have trailing spaces in them (I have no idea how they got there). I need to rename and/or delete them, but Windows won't allow me to do this. Is there a way around this problem?

I've tried to delete it via the commandline, but that did not work.

I'm running Windows XP, and it's an NTFS drive.

share|improve this question
up vote 18 down vote accepted

First try some quoting:

rd "my folder   "

Then UNC paths:

rd "\\.\C:\temp\my folder   "

Then try adding a trailing [back]slash:

rd "my folder   \"
rd "\\.\C:\temp\my folder   \"

Then 8.3 names (if they are enabled on your system):

rd myfold~1

Then a Linux LiveCD:

rmdir "/media/blahblah/temp/my folder   "
share|improve this answer
Deleting using the 8.3 names worked. Thanks – SuperFurryToad Oct 11 '10 at 15:18
Good ol DOS legacy. – surfasb Apr 2 '11 at 15:41
" " as a folder. DOS thought the 8.3 filename was "". But it worked. Super thanks! – Coomie Dec 8 '11 at 6:09
+1 for suggesting also The Linux solution – Sekhemty Dec 27 '14 at 13:01

I had the same problem, in Windows 7 x64, and none of the command-line solutions worked here.

What fixed it for me:

  • Rename the folder using 7-Zip
  • Delete, either using 7-Zip or Explorer (both work)

Note that deleting the folder in 7-Zip before renaming it was impossible.

share|improve this answer
7-Zip worked for be on a 2008R2 trailing folder that I could not delete. – user135634 May 22 '12 at 17:34
Thanks this was the only method that worked for me on a folder mounted from a remote file server – Anigel Apr 2 '15 at 10:23
wow, that really worked surprisingly well for me - thanks for the less traditional suggestion? – matt lohkamp Aug 10 '15 at 4:41

Then the DOS name:

dir /x

Then the (UNC?) name which I'm not sure how to find or what exactly it looks like:

rd \Device\HarddiskVolume1\temp\folder
rd \\?\Device\HarddiskVolume1\temp\folder
share|improve this answer
System-local UNC paths start with \\.` for devices and \\?` for files (official doc); using `\\?\C:` is often enough. – grawity Oct 12 '10 at 18:21

windows 7

I was having issues getting rid of a folder. "C:\Users\Rob\Desktop\Music\ A k o n "

This is what finally worked for me: I opened up the cmd prompt in the Music folder (shift right click, open command window here)

then typed in the following command

rd " A k o n \"

notice the back slash.

beginning spaces and trailing spaces really mess crap up. I spent at least 2 hours searching for a solution.

Thank you grawity for posting the solution.

share|improve this answer

RoboCopy seems particularly good at addressing folders/paths verbatim, so you could make an empty folder alongside the parent of the folder that has your erroneously named folder and then copy the empty folder to be the parent folder path and specify the PURGE option, which will purge the other entries in the destination folder. Hopefully you will also ensure that only bad folders are there

In summary, you want to copy 0 files into the folder that houses your bad folder, and specify /purge so that the operation clears out anything else in the folder (including your bad folder)

Confused? Then an example will surely help. Suppose you have:

C:\path\leading-to-a\folder-with-space \

Run these commands:

cd c:\path\
mkdir empty
robocopy empty leading-to-a /purge

robocopy will copy the empty folder to the leading-to-a folder, and purge the other entries in the leading-to-a folder, one of which is your folder with a trailing space:

  ROBOCOPY     ::     Robust File Copy for Windows

 Started : Thu Jan 01 00:00:00 1970

  Source : C:\path\empty\
    Dest : C:\path\leading-to-a\

   Files : *.*

 Options : *.* /COPY:DAT /PURGE /R:1000000 /W:30

                          0    C:\path\empty\
       *EXTRA Dir        -1    C:\path\leading-to-a\folder-with-spaces \

              Total    Copied   Skipped  Mismatch    FAILED    Extras
   Dirs :         1         0         1         0         0         1
  Files :         0         0         0         0         0         0
  Bytes :         0         0         0         0         0         0
  Times :   0:00:00   0:00:00                       0:00:00   0:00:00

  Ended : Thu Jan 01 00:00:00 1970


Make sure that anything you want to keep is moved out of the leading-to-a folder first!

share|improve this answer

Boot with a live CD of Ubuntu, and you will be able to delete anything you want.

To boot with the CD you should change the boot order in your BIOS settings.

share|improve this answer

Use WinRAR to find that file and rename it without the space at the end. You should be able to delete it!

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .