Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using PuTTY to SSH from my PC at home to Linux computers at work, but some of the text (folder names) is dark blue on black, which is almost impossible to read. How do I change the colour-scheme?

My computer at home has Windows 7 in case it makes any difference.

share|improve this question
up vote 28 down vote accepted

In the putty configuration window on the left side (the category section) there is an expandable item called Window and under that item is Colours. That is where color changes can be made.

share|improve this answer
thanks, much better, can i save the settings? – Kirstin Oct 12 '10 at 2:00
@Bec yes you can save the settings. In the same putty configuration window just type the host name in the text field where it says Saved Sessions then press the Save button. – ubiquibacon Oct 12 '10 at 4:20

Click on the System menu at the upper left corner of the PuTTY window.

  • Select Change Settings > Window > Colours.
  • In the box that says "Select a colour to adjust", choose ANSI Blue and click the Modify Button.
  • Slide the black arrow on the right up until you see a lighter shade of blue that you like.
  • Click OK.
  • Perform the same steps for ANSI Blue Bold so you can have a perceptible difference between the two.
  • When you're finished, click Apply.
share|improve this answer
It worked. I dont have a apply button. Make sure you select a saved Session and then change the color. Then save it! – Johan Hoeksma Jul 22 '15 at 9:32

You can use the very awesome 4bit Terminal Color Scheme Designer to generate a full color scheme for your shell.

Just create a color scheme to your liking, then click the Get Scheme button and select putty.

After downloading the .reg file, just import it to your registry to get the new color scheme. By default the registry change will only affect new sessions, but you can also apply the scheme to existing saved sessions by changing the last part of the path in the .reg file.

share|improve this answer
Brilliant solution for this age old problem! – zb226 Feb 6 '15 at 14:54

You may also want to make those colour changes to the default session so that all future sessions you save will have this.

share|improve this answer
how do i save the default session? – Kirstin Oct 12 '10 at 2:49
Click 'Default Settings' in the Session category. Then Load. Make your changes, then click Save. – Dave Jan 12 '11 at 6:40

Go to PuTTY -> Right click on the top of window -> click Change setting -> click Window -> then click colours -> click the check box named "Use system colours" && in "Select a colour to to adjust:" -> "your desired colour" -> modify -> ok -> and last click Apply. To see very clear, its very important to click check box "Use system colours" I hope it will be helpfull.

share|improve this answer
This is a duplicate of an answer that was submitted 5 years ago. – Ramhound May 29 '15 at 12:39
No, its not a duplicate answer. Actually I am fresher in IT Industry. Now I am using PuTTY. – Prinsu Kumar Varnwal May 29 '15 at 12:44
Read ubiquibacon's answer. In his answer, he explains to go to the exact same option you do, your answer doesn't provide anything new. You could also read Dennis Williamson's answer. You being a fresher has what to do with you providing duplicate information from 5 years ago? – Ramhound May 29 '15 at 12:57
Respected Mr. Ramhound, I think you didn't notice my answer. Its absolutely different from others. So please read it very carefully. – Prinsu Kumar Varnwal May 29 '15 at 13:39
I have read your answer several times, and I have came to the same outcome, several times. I have also read the existing answers which describe adjusting the colour of the text witin Putty, and with all due respect, there are 2 similar answers which result in changing the same option already and they were submitted 5 years ago. – Ramhound May 29 '15 at 14:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .