Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to run an rsync daemon on windows xp.

The symptom is that when the client connects, both server and client just sit there. Nothing happens. If I wait, the client will stay connected indefinitely.

The server logs (-vvv is specified) say this:

2010/10/11 23:02:58 [5140] rsyncd version 3.0.7 starting, listening on port 873
2010/10/11 23:03:24 [4624] name lookup failed for 192.168.15.101: No
address associated with hostname
2010/10/11 23:03:24 [4624] connect from UNKNOWN (192.168.15.101)

The client output (when -vvv is specified) say this: opening tcp connection to eddie-desktop port 873 sending daemon args: --server -vvvltrze.iLs --delete . "databackup/SomeDirectory/"

... and that's it.

Both machines are running windows.

Here is the conf:

use chroot = false
strict modes = false
hosts allow = *
log file = rsyncd.log

[databackup]
path = /cygdrive/q/databackup
read only = false
transfer logging = yes

server commmand:

C:\Program Files\ICW>"C:\Program Files\ICW\bin\rsync.exe" --config rsyncd.conf --daemon --no-detach -vvv -4

client command:

C:\Program Files (x86)\DeltaCopy>rsync.exe  -v -rlt -z --chmod=a=rw,Da+x --delete "/cygdrive/E/Data/Users/Eddie/Desktop/SomeDirectory/" "eddie-desktop::databackup/SomeDirectory/"
share|improve this question
    
as a test, I setup an rsync daemon on a different machine running mac os x, and I still got the message about the name lookup failing, but the rsync operation worked using the same client command from the same client machine as before. –  Eddified Oct 12 '10 at 5:53
    
It could be a firewall setting that allows TCP connection establishment packets but not subsequent TCP packets (a strange configuration, but not impossible). –  Gilles Oct 12 '10 at 19:05
    
all firewalls are off. –  Eddified Oct 12 '10 at 19:30
add comment

1 Answer 1

rsync is performing a reverse lookup for the client's IP address and it's not matching any allowed hosts.

Posible workarounds:

  • Upgrade to rsync version 3.1.0 and use the "disable reverse lookup" feature.
  • Add a reverse (PTR record) for the client's IP and add it to the "hosts allow" clause on the server's rsyncd.conf file
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.