Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to learn how to compile vim from the sources, because there are some additions that I want to add, and learn how to deal with this situations, but until now I didn't have success doing it, I can compile vim, but without its GUI

I think it's a dependencies problem, but I can't figure out which packages I have to install, what are the dependencies to compile vim with its gui?

I found an article about how to compile gvim, but I don't have the packages for install in my ubuntu 10.10 repositories, I hope to find some help with this

Greetings

share|improve this question
1  
As far as I can tell the tutorial you are referring to is not relying on packages at all. I mean, all dependant libraries are downloaded in source code form. Also you could be more specific about what part of compilation is giving you an error, or what dependencies are unresolved. –  Casual Coder Oct 12 '10 at 10:00

1 Answer 1

If you install the gnome-devel package, it should pull in all the dependencies you need. Then start from configure again to recognize the new package.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.