Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Because I just love to push the boat out, I have setup my Gentoo Linux box on a software RAID 1 (mirroring), I have created a volume group with logical volumes for each of the major sections of the file system. I have also put the root partition on one LV and got the system to work, which all the guides tell you not to do. However, when I shut down the system. the LVM never stops correctly, It's tricky to get the exact wording because the filesystems have already unmounted by this point, but it's along the lines of "unable to stop volume group 'main' device or resource busy"; main is the volume group which contains the root group.

Which causes a problem occasionally when I start up again. Is their a way to fix this?

share|improve this question
    
Upgrade to Debian, where that all works, and is even an easily supported thing in the installer (one of the "guided" partitioning options will even do it for you)... either that, or post a log of your shutdown messages so someone can spot the error. –  derobert Aug 8 '09 at 9:06
3  
"Up"grade to Debian? –  user4774 Aug 18 '09 at 9:39
    
I don't think changing to Debian (upgrade or not) is not an option for someone who prefers Gentoo. –  Joshua Nurczyk Aug 28 '09 at 16:34

1 Answer 1

This guy talks about making your own initrd.

share|improve this answer
    
Sadly, I have already made my own initrd, it basicly works fine, it's just this annoying one thing. –  user4774 Aug 16 '09 at 19:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.