Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm changing X's orientation with following command

xrandr -o left xrandr -o normal ...

When orientation is changing screen becomes black for a moment then it switches orientation. So how to get rid of this black screen effect ? Maybe some other options should be added to xrandr ?

Regards, Levon

share|improve this question

migrated from stackoverflow.com Oct 12 '10 at 15:05

This question came from our site for professional and enthusiast programmers.

4 Answers 4

A solution could be to use Kernel Mode Settings. It is a new feature of the Linux kernel and it does not work with all video drivers.

With kernel mode setting, blank phase may be reduced. But it may also not.

share|improve this answer

Actually I found the reason of the problem and posted corresponding bug. For details see in my blog http://levonp.blogspot.com/2010/11/xserver-black-screen-delay-when.html

share|improve this answer

Sorry, because of the way X and randr works, this is not possible.

share|improve this answer

Actually the transition from normal mode to inverted is being done very smoothly. But transition from inverted to normal mode is being done with black screen effect. Please provide more info on kernel mode settings concerning this

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.