Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The screen broke on my power PC macbook and I am trying to determine ways that I can gain access to turn remote login on so that I can at least use it as a headless server. It appears there is no way to connect to it because remote login is disabled ( ssh connection refused, direct connect via firewire fails. I am wondering if there is a way to to boot in debug mode, or boot in a mode that allows me to control it from another mac, etc. It does have a DVI output that I can connect another monitor to, but the screen is just ablank background and I cannot figure out a way to access the dock or launch terminal in the other monitors view. I tried the cmd+opt+a+v on boot to see if that would duplicate the screens ( so that the main screen would be shown on the attached monitor, and therefore I could use it) but it did not appear to do anything. Does anyone have any ideas besides loading it with an image that has remote login enabled?

share|improve this question
1  
The easiest solution was to use a second monitor and do fn+F7 a few times till the main dock is in view and controllable. However if I did not have the monitor booting the mac in target disk mode ( holding t at startup) and placing the com.apple.RemoteManagement.launchd into the /Library/Preferences folder also works well. –  ghostsource Oct 13 '10 at 19:08

4 Answers 4

up vote 2 down vote accepted

If you hold the Fn key and hit F7 while the external monitor is plugged in it should cycle through the display modes, one being that the external monitor will be the primary (or at least a mirror of the internal display). That should let you do whatever you want with it.

share|improve this answer
    
This is absolutely the quick and easiest solution. It works great if you have a second monitor! –  ghostsource Oct 13 '10 at 18:27
    
Yeah...everybody else seemed to be overengineering the problem...if you have a second monitor and you're getting an empty background on the DVI connector (indicating that its working, its just not the primary display), you're good to go, you just need to switch modes... –  peelman Oct 14 '10 at 21:32

When you say "direct connect via firewire fails", what did you try? The simplest thing to try is to boot it in target disk mode (hold t while turning it on), plug it into another computer, and see if the HD mounts on that other computer. If you have another Mac (that's compatible with the OS on that HD), you can boot it from the target-mode drive, and then edit settings to your heart's content. If not, you can mount it as a regular HD and edit settings, etc manually.

If that doesn't work, here's a variant of ghoppe's answer to enable SSH instead of VNC (that requires less blind typing):

  1. Hold commands while booting to get into single-user mode.
  2. Wait for activity to stop, then enter the commands:

    mount -uw /
    launchctl load -w /System/Library/LaunchDaemons/ssh.plist
    reboot
    
  3. After it finishes rebooting, SSH in from another computer. OS X advertises its SSH service over Bonjour, so if you don't know the computer's IP address, you may still be able to find it that supports that (e.g. OS X Terminal's "New Remote Connection" menu option).

share|improve this answer
  1. Hold down the T key while you boot to set your Mac into Firewire Target Disk Mode. Now plug it into another computer and it should appear as a disk. You have full access to read and write anything on this disk.
  2. Now, post a new question on SuperUser.com or Apple.StackExchange.com where you ask how to edit a config file (no GUI) to turn on SSH and remote desktop.

Hint: To turn on Remote Desktop from the command line, you would type this:

cd /Library/Preferences
echo -n enabled > com.apple.ScreenSharing.launchd

Note: Those commands are for the computer your are logged in on. You might need to cd /Volumes/TargetDisk/Library/Preferences in order for this to have the desired effect in your situation.

Now, eject your damaged Mac, Reboot, and you should be able to connect to it with VNC, and turn on SSH via the GUI, assuming you couldn't find the commands to enable SSH while it was attached as a disk to the other computer.

share|improve this answer
    
So i have another mac book with 10.5 and it generates two files /library/Preferences/com.apple.RemoteManagement.plist and /library/Preferences/com.apple.RemoteManagement.launchd. The launchd just has the value "enabled" printed in it, the same as the post here. This allows remote management.The plist had 5 dictionary values none of which seemed critical, so it probably isn't needed. –  ghostsource Oct 13 '10 at 19:04
    
Actually as suggested by @Gordon, boot your other mac (if also PPC) off this. 1) Boot this in Target mode. 2) Connect with FireWire. 3) Boot Mac with working monitor and hold down the Option key 4) Select this drive. –  user31752 Oct 13 '10 at 19:07
  1. Hold down commands while booting to boot in single-user mode.
  2. Wait for the hard drive to stop grinding, so you know you've got a command line, then type in the command shown below to enable Remote Desktop -- this will be tricky because you can't see what you type. Good luck. =)
  3. After you hit return, you'll have to enter your administrator password and hit return again.
  4. Type reboot and return, wait for the system to load completely and hopefully you can then log in remotely.

sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -activate -configure -access -on -clientopts -setvnclegacy -vnclegacy yes -clientopts -setvncpw -vncpw mypasswd -restart -agent -privs -all

(note: technically, I don't think sudo is necessary in single-user mode, but it doesn't hurt.)

share|improve this answer
    
+1: very cool ! –  Paul R Oct 13 '10 at 15:17
    
You need to enable write access to the boot drive first with mount -uw / –  Gordon Davisson Oct 13 '10 at 16:34
    
I tried this, and it did not go so well, but I have to say it is a creative solutions. –  ghostsource Oct 13 '10 at 19:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.