Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I'm logged in as a user that is not member of the administrator group the entry to create a new text file is missing from the right click "New" menu.

If I give the user administrator rights or start Explorer with admin rights the New → Text document menu entry magically appears.

As far as I can see the registry entries are correct.

What's the solution for the side effect of being a normal user in Windows 7?

share|improve this question
    
try using Ctrl+Shift+N, you may like it :D –  nXqd May 18 '11 at 0:59
    
@nXqd that creates a new directory. –  Stijn Nov 20 '11 at 14:16

2 Answers 2

In my case, Windows XP Pro SP3, the New Text Document disappeared a little while back. I tried to use PowerToys TweakUI Templates, but even though it was selected to be on, did not cause Text Document to show up any more.

So I used this article as a "hint" and looked into HKCR and found a strange entry which I fixed. This worked for me. Details below:

Regedit

My Computer\HKEY_CLASSES_ROOT\.txt

change the "(Default)" value from String "txt_auto_file" to "txtfile"

Close Regedit. Done.

(how it got messed up as txt_auto_file, don't know)

share|improve this answer

I found several references to solutions to this problem. They all involve registry hacks -- most suggest to add some new entries to HKEY_CLASSES_ROOT or HKEY_LOCAL_MACHINE/Software/Classes/ (which I believe are equivalent).

Specifically, the following reg hack seems to solve the problem for most folks:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.txt]
@="txtfile"
"Content Type"="text/plain"
"PerceivedType"="text"

[HKEY_CLASSES_ROOT\.txt\PersistentHandler]
@="{5e941d80-bf96-11cd-b579-08002b30bfeb}"

[HKEY_CLASSES_ROOT\.txt\ShellNew]
"ItemName"="@%SystemRoot%\system32\notepad.exe,-470"
"NullFile"=""

Cut and paste into a new .reg file to auto-merge it into your registry. I recommend first checking each of the values/keys shown here in regedit to see what changes (if any) you are making.

However, this did not work for me, as I had a conflicting empty entry in HKEY_CURRENT_USER. In fact, the keys/values were all already in HKEY_CLASSES_ROOT, so the first set of changes didn't do squat. So... I also merged in an identical version of this using HKEY_CURRENT_USER, which worked:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\SOFTWARE\Classes\.txt]
"PerceivedType"="text"
@="txtfile"
"Content Type"="text/plain"

[HKEY_CURRENT_USER\SOFTWARE\Classes\.txt\PersistentHandler]
@="{5e941d80-bf96-11cd-b579-08002b30bfeb}"

[HKEY_CURRENT_USER\SOFTWARE\Classes\.txt\ShellNew]
"ItemName"="@%SystemRoot%\system32\notepad.exe,-470"
"NullFile"=""
share|improve this answer
1  
The second reg file also worked for me. I never knew how much I depended on this feature until it was gone! –  Chris Fletcher Jun 27 '13 at 15:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.