Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to setup a homegroup between two Windows 7 computers, and apparently my Eset Security Service is blocking the traffic. When I disable the firewall on both computers, the homegroup works fine. Is there a known fix/workaround for it?

share|improve this question

1 Answer 1

Go to Setup -> Personal Firewall -> Change the protection mode of your computer in the network -> click it -> Choose Allow Sharing

Also check Setup -> Personal Firewall -> Advanced personal firewall setup -> IDS and advanced options -> check Allow file and printer sharing in the Trusted zone

If you are using interactive filtering mode check the rules that you have set in accordance to network traffic

Hope this helps!

share|improve this answer
Thanks for the effort, by both computers are in interactive mode, I didn't block anything that looks related to Homegroups (Anything at all, so far), I have selected "Allow Sharing", and allowed file and printer sharing on both computers. Still - no homegroup or even normal network sharing (I guess they are just the same "underneath") unless I disable the firewalls on both computers. Do you use such Homegroups with two ESS 4.0? – Noam Gal Aug 8 '09 at 16:19
Set the firewall to automatic filtering mode and check if it networks correctly.. if it works then its just a matter of finding the rule which is blocking it – rzlines Aug 8 '09 at 17:18
I'm an XP user primarily but i have networked successfully with my Vista laptop .. sometimes in the interactive mode i would block windows explorer or some other windows system component from sending and recieving requests and my internet or network would get blocked .. firewalls are quite irritating sometimes.. do tell what happens when u switch to automatic filtering as it could just be some silly rule which u feel is unrelated to networking that would be blocking it – rzlines Aug 8 '09 at 17:26

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.