Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Tried installing Linux (Red Hat 5) along with Windows 7. I created a new partition (10 GB in size) and used it for the Linux installation. After install, I was getting GRUB geom error and my system wasn't booting.

After a few tries I had to format my entire hard disk and run fixmbr which came up with the following warning message:

A new MBR will be created and some of the partition may become inaccessible

Now, even though I have gotten back Windows, the Linux partition is not at all visible. (Seems like the warning message has become a reality as that partition looks like has become inaccessible.)

My new hard disk capacity has also reduced by 10 GB and it is not showing up using any software.

How can I recover that inaccessible partition?

Edit

I tried fdisk via Linux Rescue disk. Got an error 22, the details as follows:

Command (m for help): w 
The partition table has been altered! 
Calling ioctl() to re-read partition table. 
WARNING: Re-reading the partition table failed with error 22: Invalid argument 
The kernel still uses the old table. 
The new table will be used at the next reboot. 

No luck booting in Windows.

share|improve this question

migrated from stackoverflow.com Oct 13 '10 at 16:07

This question came from our site for professional and enthusiast programmers.

    
"red hat 5"? RHEL 5? –  Ignacio Vazquez-Abrams Oct 13 '10 at 16:10

2 Answers 2

Boot up with a Linux live or rescue disk, run fdisk, and delete the 10GB partition from there.

share|improve this answer

Super Grub is awesome. It'll fix your boot loader. http://www.supergrubdisk.org/

Burn the ISO to a disk, stick it in your drive, reboot, boot from disk, follow the instructions. Works like a charm. :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.