Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Acer notebook has a button that can disable the wireless network device when pressed. Since it is near the ESC key, sometimes I press it on accident, especially when editing something with Vim. When I press the wireless switch to enable the device again, nothing happens. Using the command ifconfig wlan0 up results in the following error:

SIOCSIFFLAGS: Unknown error 132

Rebooting and logging on linux again didn't solve anything. I had to log into windows. The device started out disabled, then pressing the button reenabled the device. I'd like to be able either to reenable wireless at will, or outright disable the wireless switch button. How do I solve this?

share|improve this question
add comment

2 Answers

You probably need to modify the hal configuration in order for the button to be recognized properly.

share|improve this answer
add comment

This doesn't directly answer your question but its a good tip for Vim users. If you don't use your caps lock key, you can change your caps lock key into an escape key using xmodmap. Just put the following lines in a file in your home directory called .Xmodmap

remove Lock = Caps_Lock
keycode 66 = Escape

Then run this to activate it:

xmodmap - < .Xmodmap

Most distributions will read that file automatically when you login to X.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.