Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Whenever I use my iPod Touch G4 (iOS 4.1) at home, I cannot play Youtube videos using the Youtube app. The lists of videos shows correctly, but when I tap to play a video and the video toolbar shows up, a dialog box shows "The server is not correctly configured" and the video is not played. When I turn off my Privoxy (v3.0.15) proxy, the video plays correctly.

How can I use Privoxy as the global default proxy while still retaining Youtube App functionality?

share|improve this question
    
Is there a question here? – Velociraptors Oct 13 '10 at 23:03
    
Edited to include a direct question. – piyo Oct 13 '10 at 23:08

It turns out some default Privoxy options are adding/modifying the HTTP response in a way that the Youtube app cannot understand. I added the following to my user.action file:

{ fragile -deanimate-gifs }
.googlevideo.com
.youtube.com

and the videos can now play. The "Final result" when using the Privoxy Show Info page is shown below:

Final results:

+change-x-forwarded-for {block} 
+hide-from-header {block} 
+session-cookies-only 
+set-image-blocker {pattern} 

-add-header 
-block 
-client-header-filter 
-client-header-tagger 
-content-type-overwrite 
-crunch-client-header 
-crunch-if-none-match 
-crunch-incoming-cookies 
-crunch-outgoing-cookies 
-crunch-server-header 
-deanimate-gifs 
-downgrade-http-version 
-fast-redirects 
-filter 
-force-text-mode 
-forward-override 
-handle-as-empty-document 
-handle-as-image 
-hide-accept-language 
-hide-content-disposition 
-hide-if-modified-since 
-hide-referrer 
-hide-user-agent 
-limit-connect 
-overwrite-last-modified 
-prevent-compression 
-redirect 
-server-header-filter 
-server-header-tagger

Some online searches show that some people have success with "Enable HTTP Byte-Range" requests, but I don't see a similar option.

Edit: Added and verified ".youtube.com". Also adding ".vimeo.com" for the Vimeo service works.

share|improve this answer
    
It worked for my case. BTW, I had to add .youtube.com instead of .googlevideo.com. Thanks a lot. – shr Aug 15 '12 at 4:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .