Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Restarting my computer via Windows 7 will turn off windows and the screen will go black and remain black. Whenever I restart and I get to the black screen, I have to force shutdown or force restart for the computer to properly run.

What could be causing this? Note: Shutting down works fine, it's just the restart that doesn't work properly.

share|improve this question
add comment

4 Answers

up vote 2 down vote accepted
  1. Have you tried starting up/restarting in Safe Mode? Does that work?
  2. Use a tool like Autoruns to find out which tasks/apps/services are running on startup. See anything there that might cause an issue? Maybe an app you haven't seen before?
  3. Do you experience any hard disk issues? Upon restarting, usually paging file operations are written or erased from the disk. This is quite a big file, usually found on the system partition (although might be configured differently). Check your disk to see if that's the issue.
  4. And the always-present explanation: check your machine for viruses, malware or rootkits - they cause all kinds of bizarre behavior.

Good luck!

share|improve this answer
    
I actually did have some malware and a rootkit a few weeks back. I thought everything was cleared, but Autoruns turned up two things that when I deleted them, I was able to restart again. Thanks! –  Omar Oct 15 '10 at 7:23
add comment

Well the first thing i'd ask is what kind of video chipset/GPU do you use - is it onboard? I had this same annoying problem when I built a custom PC back in 2007; the onboard Nvidia GeForce 6150 chipset simply could not let my computer restart when the monitor refresh rate was set to 75Hz. I had to throttle it down to 60Hz before it could restart.

Amazing, ain't it?

share|improve this answer
add comment

"PME Event Wake Up" must be enabled in bios settings. Solved for me.

share|improve this answer
add comment

As a tech I have encountered this problem twice now and both times fixed it by removing CMOS battery and putting it back in.

share|improve this answer
    
Your answer might benefit quite a bit from giving the reasons why CMOS battery removal helps. –  Sami Laine Apr 13 at 4:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.