Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.


I am accessing network drive (Z:\stream) on windows. Now the permission set on stream folder is like chmod -R 777 streams/ means all the files inside stream is at 777 but now i am copying some files from windows to this streams folder but permission on those files are not 777 ,i would like to have permission 777 on those files that copied from windows ...how do i do that??

share|improve this question

migrated from stackoverflow.com Oct 14 '10 at 6:37

This question came from our site for professional and enthusiast programmers.

2 Answers 2

On linux:

Once you copy, you can run chmod again

chmod -R 777 <dir>

share|improve this answer
    
but i can't go to linux machine again from windows i have to do that... –  AMIT Oct 14 '10 at 6:31

If your Windows version allows it, use the standard Windows file permission interface under Properties → Security and grant "Read", "Write" and "Execute" (or simply "Full control") permissions to all items listed. (There should be three; the owner, the group, and "Everyone"). Samba will automatically translate them to Unix permissions or to POSIX ACLs.

Windows security properties

A command-line method, one that only works for setting 0777, is cacls myfile /g Everyone:F.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.