Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Anyone with some Excel expertise please help me with this...

I'm trying to copy and paste 4 digit hexadecimal numbers (eg. 0001, 0002, all the way through to 03D2) but Excel keeps formatting them, 0001 becomes 1, while some hex become '####' which is strange. How would I stop this autoformatting? Note I only want to turn it off just for this time. Cheers.

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Format all the necessary cells as "Text" in the worksheet you're going to paste to. And then use Paste special->values

That should do the trick

share|improve this answer
    
Nice, thank you very much kind person :D –  FlavorOfLife Oct 14 '10 at 13:13
add comment

Before you paste the data set the column to be text in the formatting options and make sure you are pasting simple text eg Use Paste special and text.

If you need to do Maths on the numbers use HEX2DEC() to convert the field to decimal and to go back to Hex use DEC2HEX()

share|improve this answer
    
I'll keep this in mind when I need to convert, thanks :D –  FlavorOfLife Oct 14 '10 at 13:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.