Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
Different available keyboard layouts in language bar and Text Services and Input Languages

I have the following problem on a Windows 7 machine: a set of languages is automatically self-installed which includes Korean, Chinese, and Japanese languages.

I've tried removing them manually from time to time from a language bar. However this doesn't help and they keep getting reinstalled.

How can I remove them for good?

share|improve this question

marked as duplicate by Randolph West, Sathya Jul 24 '12 at 4:10

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

up vote 8 down vote accepted

I had exactly the same problem on a Windows 7 64-bit machine. I accidently added the Asian language support and was left with three extra keyboard layouts after each restart (KOR, JPN, CHS). This is what I did to fix it:

Note: please read the whole thing before going step-by-step; you may find that starting with step 7 will be more comfortable for you rather than starting with step 1.

  1. Remove the Korean, Japanese and Chinese keyboards from the keyboard list
  2. Press Win-key + R to open the "run" command window
  3. Input: regedit then press ENTER - this will open the Windows Registry
  4. Navigate to the following key:

    HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
    
  5. You will find three items referring to:

    "c:/program files/common files/microsoft/imei14/shared/imeklmg.exe /uninstall /CHS /log"
    "c:/program files/common files/microsoft/imei14/shared/imeklmg.exe /uninstall /JPN /log"
    "c:/program files/common files/microsoft/imei14/shared/imeklmg.exe /uninstall /KOR /log"
    

    Delete all of them.

  6. You may also find the same items from step 5 under:

    HKLM\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run
    

    If so, delete these as well.

  7. If you are not confident with modifying the registry you may do the following instead of steps 2-6: deselect the above mentioned startup commands by doing this:

    1. Start > Control Panel > Administrative tools > System configuration
    2. In the System Configuration window go to the Startup tab
    3. Uncheck all items called "Microsoft Office IMEI 2010" that have the paths from step 5 under the "command" column
    4. You can always come back and re-check these items if you need to
  8. Restart your computer

Hopefully after restarting you will no longer have the additional keyboards.

share|improve this answer
    
Worked like a charm! +1! –  tftd Feb 18 '12 at 21:22

Not the answer you're looking for? Browse other questions tagged or ask your own question.