Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have issues running the following command:

root@X100e:~# apt-get dist-upgrade 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  adduser apt apt-utils base-files base-passwd bash bash-completion bsdmainutils bsdutils busybox-initramfs consolekit coreutils
  cpio cpp cpp-4.4 dash dbus debconf debconf-i18n debianutils diffutils dpkg e2fslibs e2fsprogs file findutils gawk gcc-4.4-base
  gcc-4.5-base gpgv grep gzip hostname ifupdown initramfs-tools initramfs-tools-bin initscripts insserv klibc-utils libacl1
  libattr1 libblkid1 libbz2-1.0 libc-bin libc6 libck-connector0 libcomerr2 libdb4.8 libdbus-1-3 libdbus-glib-1-2 libdconf0
  libdrm-intel1 libdrm-nouveau1 libdrm-radeon1 libdrm2 libeggdbus-1-0 libexpat1 libgcc1 libgdbm3 libglib2.0-0 libglib2.0-data
  libgmp3c2 libgpm2 libklibc liblocale-gettext-perl liblzma2 libmagic1 libmpfr4 libncurses5 libncursesw5 libnih-dbus1 libnih1
  libpam-ck-connector libpam-modules libpam-runtime libpam0g libpcre3 libplymouth2 libpng12-0 libpolkit-gobject-1-0 libreadline6
  libselinux1 libsepol1 libslang2 libsqlite3-0 libss2 libssl0.9.8 libstdc++6 libtext-charwidth-perl libtext-iconv-perl
  libtext-wrapi18n-perl libudev0 libusb-0.1-4 libuuid1 libx11-6 libx11-data libxau6 libxcb1 libxdmcp6 libxml2 login lsb-base make
  makedev mime-support module-init-tools mount mountall ncurses-base ncurses-bin net-tools netbase passwd perl perl-base
  perl-modules plymouth plymouth-theme-ubuntu-text procps psmisc python python-minimal python2.6 python2.6-minimal readline-common
  sed sensible-utils sgml-base shared-mime-info sysv-rc sysvinit-utils tar tzdata ubuntu-keyring udev upstart util-linux
  uuid-runtime xml-core xz-utils zlib1g
0 upgraded, 141 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/49.7MB of archives.
After this operation, 177MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
E: Could not perform immediate configuration on 'libbz2-1.0'.Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)

Unfortunately I don't have a clue where the problem is... Any ideas how to fix this?

Note: I also thought to reinstall apt. Is this possible?

Thanks, Udo

Update:

running

root@X100e:~# aptitude full-upgrade 
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.

results in the same error...

running

root@X100e:~# aptitude -vv full-upgrade 
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.

Current status: 0 broken [+0], 0 updates [+0], 3390 new [+0].

results in the same error...

Also tried with -vvv and -vvvv -> same result.

share|improve this question
1  
Try aptitude full-upgrade. Aptitude is a mostly compatible replacement for apt-get, with better dependency handling (and more features). If it doesn't work, run aptitude -vv full-upgrade (or maybe even more vs), and if you get better error messages, add them to your question. –  Gilles Oct 14 '10 at 23:00
    
thanks Gilles, see update in my question. unfortunately not working... p.s.: post your help as an answer, so I can honor it ;) –  udo Oct 15 '10 at 9:31

3 Answers 3

up vote 6 down vote accepted

Very probably, you've got a problem updating the dpkg package, just like me. Go to /var/cache/apt/archives and very carefully, do a dpkg -i of the problematic package.

I myself have done tonight this:

sudo dpkg -i dpkg_1.15.8.4ubuntu3_amd64.deb libbz2-1.0_1.0.5-4ubuntu1_amd64.deb libselinux1_2.0.94-1_amd64.deb coreutils_8.5-1ubuntu3_amd64.deb libacl1_2.2.49-3_amd64.deb libattr1_1%3a2.4.44-2_amd64.deb

Of course, your package versions should be different, or we'll have found a bug at Ubuntu's side.

Then do the same command with your hopefully small set of .debs with the option --force-depends.

Play alternating with the two commands to get everything installed and configured, and you'll be ready to go.

Now, I've got the same error with another package, did the same again, and now my system is working.

Conclusion: just had to manage the dependencies by hand a bit to get it to work.

share|improve this answer
    
thank you very much Saiyine -> perfect! -> exactly what was needed. unfortunately I'm stuck somewhere else (probably not related to this issue) and posted a new question (superuser.com/questions/200065/…). –  udo Oct 16 '10 at 9:14
1  
This definitely helped me. However I used a less brute-force approach. Take the name of your package and do sudo dpkg -i <package> it will fail, note the name of the new package and then run dpkg -i <newpackage> do this until a package install, then drop back to run everyone on the chain. After that dist-upgrade will work again –  jorge.vargas Feb 9 '11 at 21:26

I had this exact problem and solved it like so:

apt-get install -o APT::Immediate-Configure=false -f apt python-minimal
apt-get -f install
dpkg --configure -a
apt-get dist-upgrade

This solution comes from a combination between https://bugs.launchpad.net/ubuntu/+source/python-defaults/+bug/990740 and http://ubuntuforums.org/showthread.php?t=1451594

share|improve this answer

I had the same problem. I resolved my problem by upgrading libc6 as a separate step:

apt-get install libc6

Then

apt-get dist-upgrade
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.