Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

TextMate newbie here.

I hate to have to grab my mouse to click that Regular Expressions box nearly every time I search.

EDIT: the Regex check box becomes unchecked anytime after using ⌘-F in Safari.

share|improve this question
1  
I check it and it stays checked. At least as long as I have TextMate open. Version 1.5.9 (1510) on 10.6.4. –  Ian C. Oct 15 '10 at 1:37
1  
I'm on the same. Try using ⌘-F in safari, then coming back to TextMate and doing it. –  Derrick Oct 23 '10 at 3:20
add comment

1 Answer

Do you have the latest version of TextMate? On mine it remembers across launches/reboots. Go to TextMate -> Preferences, then Software Update. Under Watch For: select Cutting-Edge. Then select Check Now and install the update.

share|improve this answer
    
I was on build 1509. Thanks for letting me know about the cutting edge builds. I just updated 1589. Unfortunately I have the same behavior. But please see my edited post, because I originally explained the problem wrong. –  Derrick Nov 7 '10 at 1:38
    
I actually tested this (Cmd+F in TextMate, switch to Safari, Cmd+F, Switch to TextMate, Cmd+F) and it still stays checked. Same with using Safari's Cmd+F between launches of TextMate. At this point I'm stumped... –  Justin Mrkva Nov 7 '10 at 2:15
    
even when hitting the next button (or cmd-G) in safari? –  Derrick Nov 13 '10 at 11:03
    
Nope, it works fine. Can you post the exact sequence? i.e. (Launch Safari) -> (Launch TextMate) -> (Find, check "Regular Expression") -> (Switch to Safari) -> (Find and Cmd+G) -> etc.? That would help if you could post an exact sequence that will duplicate the problem. Be sure to start with TextMate and Safari both quit, end with them both quit, and go through the sequence twice to be sure. –  Justin Mrkva Nov 16 '10 at 2:43
    
Follow-up: I've just found a way. Start with both closed. (Launch Safari) -> (Launch TextMate) -> (Cmd+F, check Regex, Cmd+W) -> (Switch to Safari) -> (Cmd+F) -> (Type Something in the Search Field) -> (Cmg+G) -> (Esc) -> (Switch to TextMate) -> (Cmd+F). That results in the text you entered filling the search field and the regex box unchecked. It seems that what triggers this is when you actually enter something in the Safari search field; TextMate takes that text and fills its search box, with the regex box unchecked. –  Justin Mrkva Nov 16 '10 at 2:46
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.