Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install CouchDB on my mac, running snow leopard 10.6. I installed Xcode, MacPorts, and then followed the instructions here: http://wiki.apache.org/couchdb/Installing_on_OSX

It all worked fine until I tried to visit the web interface: http://127.0.0.1:5984/_utils/index.html

Google chrome said "Oops! Google Chrome could not connect to 127.0.0.1:5984"

I tried connecting using telnet in bash and it said connection refused. Can somebody shed some light with some suggestions or perhaps and idiot-proof walkthrough?

share|improve this question

Just install Homebrew https://github.com/include/homebrew , then:

$ brew install couchdb

have fun

share|improve this answer

With homebrew, you have to do this after the installation :

Edit the key UserName in ~/Library/LaunchAgents/org.apache.couchdb.plist then make sure the user owns these folders :

  • /usr/local/var/log/couchdb/
  • /usr/local/var/lib/couchdb/
  • /usr/local/etc/couchdb/

or simply use couchdbx !

share|improve this answer

I struggled the same thing for a couple of days. I finally the following link, which provides it as a simple mac app (download CounchOne), with GUI tool packaged for you. You don't have to deal with permission and dependency.

http://www.couch.io/get

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .