Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have run into a very interesting issue with my Macbook Pro. My Macbook Pro is a Revision C, late 2006, 2.17 gHz machine, standard configuration, except I maxed the ram to 3 GB. I run both OSX and Windows (via bootcamp).

The short story:

  1. The remote does not work on OS X. Just having the desktop up, there is no response to the remote buttons. Going into the System Settings -> Security and trying to pair results in no response either. Disabling the IR in that dialog and re-enabling has no effect.

  2. The remote does work at the machine's boot menu - I can use it to move back and forth between the OSX and Windows icons and use the select button to choose the OS to boot.

  3. The remote does works on my Windows 7 Ultimate installation (BootCamp drivers enabling the IR since "Apple IR Receiver" show up in the Device Manager under the Human Interface Devices category). In particular, this is evidenced by using the volume controls on the remote and the laptop responds with volume changes. I imagine I could do more troublshooting to show that all the buttons do in fact respond, however I probably need to install a third party program to translate the remote buttons, such as ARW, although it seems the sourceforge site is now down.

So this seems really, really odd for it to not work in OSX, but work in Windows; however it also provides a fairly good comparison/troubleshooting view into what could be wrong. Where should I go from here? Has anyone experienced issues like this? I'm more experienced with hardware issues on Windows than OSX so I'm not sure where to go from here.


  • I noticed the remote would work shortly after logging in, for about 15-20 seconds maximum.
  • I create a separate account, logged on, the remote continued working.

Something specific to my user account disables the remote/IR functionality. Any ideas? I have checked Login Items under my account name in Security and the only item is iTunesHelper.

share|improve this question

Has it ever worked in OS X? It may be because you have installed a program that has taken over the remotes functions, such as Boxee or Hulu Desktop?

There are a few apps that can take over your remote and render it useless unless that particular application is open.

share|improve this answer
boomcubist - good question - I do have boxee installed, I will test tonight. Also, it has worked on that account before, in the past. Read above about how it works on one account and not the other - this would seem to align with your suggestion that another peice of software is blocking it somehow. – mindless.panda Oct 18 '10 at 15:55
up vote 0 down vote accepted

After narrowing it down to my specific account where the remote would not work on the OS X installation (not Windows), I decided it was about time for a reformat given that I could not isolate what was causing the problem on my account, software or settings.

I'll point out that I've installed a number of programs that could have caused potential conflicts given their features (some sort of remote interaction):

  1. Logitech iPhone app.
  2. Boxee
  3. Griffin Proxi

and a few more I'm sure I'm forgetting.

Reinstalling of course fixed the problem.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .