Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I did not run into this problem until I upgraded my Ubuntu box to Maverick Meerkat (10.10). Basically, whenever I start my computer, conky runs as expected, except it gets drawn over any windows that I load (see screenshot below). To fix this for a single session, I simply restart conky by running

killall conky; conky

in a terminal. Conky gets re-drawn below active windows (namely, only appearing on my desktop), and does not have the border/drop-shadow, but I have to do this every time I start a new session. Is there a simple way to fix this?

screenshot

I have a small shell script that I run on startup, but it does not seem to solve the problem.

#!/bin/bash
sleep 10 && conky;
sleep 5 && killall conky; conky;

Below is the non-text part of my .conkyrc file.

# Conky settings #
background yes
update_interval 1

cpu_avg_samples 2
net_avg_samples 2

override_utf8_locale yes

double_buffer yes
no_buffers yes

text_buffer_size 2048
#imlib_cache_size 0

temperature_unit fahrenheit

# Window specifications #

own_window yes
own_window_type override
own_window_transparent yes
own_window_hints undecorate,sticky,skip_taskbar,skip_pager,below

border_inner_margin 0
border_outer_margin 0

minimum_size 200 250
maximum_width 200

alignment tr
gap_x 220
gap_y 280

# Graphics settings #
draw_shades no
draw_outline no
draw_borders no
draw_graph_borders no

# Text settings #
use_xft yes
xftfont caviar dreams:size=8
xftalpha 0.5

uppercase no

temperature_unit celsius


default_color FFFFFF

# Lua Load  #
lua_load ~/.lua/scripts/clock_rings.lua
lua_draw_hook_pre clock_rings
share|improve this question
    
I was about to say "that doesn't look like any Conky I've ever seen, you gkrellm-using liar." But then I saw the Lua scripts at the bottom. –  amphetamachine Aug 31 '11 at 8:41
add comment

migrated from stackoverflow.com Oct 15 '10 at 16:41

This question came from our site for professional and enthusiast programmers.

2 Answers

don't know if this will work, somewhere i saw the following :

on_bottom yes
share|improve this answer
    
That's what the own_window_hints ... below is for. –  amphetamachine Aug 31 '11 at 8:43
    
This is what solved the problem for me. Disabling own_window made it render funny and try and hide from my mouse clicks. –  stw_dev May 7 '12 at 14:31
add comment

If GNOME changed the way it handles window manager hints (which seems the be what's happening with the whole GTK-3.0 + Unity desktop shift that's been happening), then it may be a matter of just circumventing the window manager and just drawing to the X root window. I assume it still has one underneath all the bells and whistles, right?

This is the applicable line in my ~/.conkyrc (I use Fluxbox):

# DO NOT create own window instead of using desktop
own_window no
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.