Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Netgear Stora MS2110 network attached storage has one hard drive in it. I can "see" the Stora on the network (ping responds and URL shows the three usual folders: Family Library, MyComputers and MyLibrary). Going into these folders says "Windows cannot access \Stora\MyComputers...".

The blue power light is on solid and the green hard drive LED is blinking constantly. (According to manual, this means the HD is either booting up or shutting down, or is accessing data - it says if the HD is bad the LED should be amber).

Power button on the back doesn't respond. To power it down, I must unplug the power cord.

Reset button doesn't help (the green LED goes out, then both green LED's blink six times as the manual says it should, but then a moment later the one green LED is back to blinking incessantly).

I tried powering down and putting the drive into the other bay, same behavior.

If it is necessary to reformat this hard drive, I am willing to do that, I just want it to be available to my PC again.

Thanks!

share|improve this question

1 Answer 1

up vote 0 down vote accepted

The drive itself was bad. I got a new one to replace it, and problem solved.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.