Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Western Digital 500GB External USB drive. Everytime I plug it in, one of my Win7 PCs label it as "VMWare USB Device"

The same name appears under Devices and Printers. Device Manager and most other places I've checked display the device name properly.

Obviously, this is just a minor annoyance. But Annoyance nevertheless. :-p How do I fix this? I scanned through the registry but found multiple matches for "VMWare USB Device". So, I'm not confident renaming from the registry.

share|improve this question
    
Does the drive still work normally, as you would expect? I.e, can you copy/delete files? Does it show up with a drive letter in Computer Management -> Storage -> Local Storage? –  Chris Thompson Oct 17 '10 at 4:05
    
Yes, it works perfectly normal except for the wrong labeling. And it does show under local storage. –  user16170 Oct 18 '10 at 11:15

4 Answers 4

up vote 2 down vote accepted

I think its cause windows will associate that device with vmware. I fixed it by using Nirsoft UsbDeview

enter image description here

It lets you view the usb devices installed on your computer. just run as administrator and uninstall the hard drive. When you plug your hard drive in, it will install it again as its original name.

share|improve this answer
    
This worked. The devise is now simply labeled External HDD, rather than its real name ("WD 5000AAV External USB Device). But, this is good enough. Thanks! –  user16170 Dec 16 '10 at 1:58

Do you have VMware installed with automatic USB passthrough?

share|improve this answer
    
Where should I look for this setting? Btw, this happens ONLY for this particular drive. It is possible that I had VMWare running the very first time I plugged the device in to the machine. But, now this happens without VMWare player/workstation running. –  user16170 Oct 18 '10 at 11:17
    
What you need to do is disable the "Automatically connect new usb devices" option in the Options for a virtual machine in VMWare Workstation/Player. screencast.com/t/AndKFgzmAi for a picture of how to do this in Workstation. –  brandon927 Nov 15 '10 at 7:13

This usually happens if VMWare Workstation/Player is open and active at the time that you plug in a USB device. I have never seen it happen when neither program is actually active.

This is used to pass the USB device into a virtual machine directly - the "VMWare USB Device" you are seeing on the host is simply a dummy driver used for the passthrough.

You can either go to the running virtual machine and look for the Removable Device section and then look for USB and choose the device followed by Disconnect

Alternatively, if it is causing problems, you can go to Services ( click Start Orb, Right click Computer, click Manage then look for Services under Services and Applications) and stop the service named VMware USB Arbitration Service.

(Previous step can also be done from the command line by SC stop VMUSBArbService)

share|improve this answer
    
Nope, it shows up even when VMWare was not running (not even VMWare tray). As I stated in another comment, the device is actually working as it should on the host machine other than the label. Stopping the Arbitration Service didn't help either. Disabled the service and restarted. Still it says "VMWare USB Device".. so annoying :) –  user16170 Oct 18 '10 at 13:13

The only way I could find that could restore the correct names of your USB devices is to uninstall VMWare entirely.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.