Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After installing Linux Mint on my laptop, I found that plugging in a speaker to the headphone jack did not mute the speakers. I followed the instructions here to upgrade my ALSA driver, and now my headphone jack doesn't even output any sound at all. Is there a known fix for this? Here is some information that will probably prove useful:

$ cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.23.
Compiled on Oct 16 2010 for kernel 2.6.32-21-generic (SMP).

$ cat /proc/asound/card0/codec#* | grep Codec
Codec: Conexant CX20583 (Pebble HSF)
Codec: Intel G45 DEVCTG

I'm at a loss as to what to do. If there is more information that would be helpful, please tell me and I'll provide it.

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

I installed some new ALSA drivers from Linuxant: http://www.linuxant.com/alsa-driver/, and after rebooting the sound worked exactly as expected.

share|improve this answer
add comment

I had the same problems and tried linuxant, but for me it made the driver not work at all. After reinstalling all the original packages, what fixed it for me was adding "options snd-hda-intel model=ideapad" to /etc/modprobe.d/alsa-base.conf

Fix was found here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/680844

Configuration:

linux mint 10, amd64

$ cat /proc/asound/card0/codec#0 | grep Codec

Codec: Conexant CX20585

$ cat /proc/asound/version

Advanced Linux Sound Architecture Driver Version 1.0.23.

$ cat /etc/modprobe.d/alsa-base.conf | grep snd-hda-intel

options snd-hda-intel model=ideapad

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.