Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a home network with the following computers:

  • Windows XP SP3 (workgroup: MSHOME)
  • Ubuntu 10.04 LTS (Samba, workgroup: MSHOME)
  • Windows 7 Ultimate company laptop (domain: XYZ)

XP <--> Ubuntu works fine

Both XP and Ubuntu are on the same workgroup, and they can access each other's shares just fine.

Win 7 <--> XP works fine

My Win 7 work laptop (member of a domain) can also access shares on the XP box (using credentials <hostname>\<username> and <password>), even though the laptop is not a member of the MSHOME workgroup.

Win 7 <--> Ubuntu ... not so much

For some reason, I can't access shares on the Ubuntu box from my laptop. I can see the shares if I type \\<hostname>\ into Win7 Explorer. However, clicking on a displayed share in Explorer produces a credentials prompt, and no matter what I enter, I get a permission denied message.

Interestingly, I get a slightly different error message if I type in an intentionally incorrect password, so I believe things are working up to a point...

The Samba Server Configuration app in Ubuntu has some different Authentication Mode settings. The default is User, and I haven't changed it.

Has anyone dealt with this configuration (Win7-domain / Samba-workgroup)?

Any help would be greatly appreciated. I've been searching online and trying various things, but no joy. I don't know how to see what's actually happening behind the scenes, so it's just down to trying every combination I can think of until it works...

share|improve this question
add comment

1 Answer

I suspect the Windows 7 laptop is automatically adding domain XYZ to the username. Have you checked the logs on the Samba server to see what it's reporting?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.