Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Tried playing downloaded 720p MKVs (x264), but at some points the picture gets garbled and there are sync problems between audio and video. The audio is normal though. It's the video that lags or breaks up.

I'm using VLC and Windows Media Player mostly. Recently, I tried Zoom Player and some of the 720p MKVs played fine, but others exhibit noticeable lags in video.

Below are the specs:

Motherboard: MS-7312
CPU: Athlon 64 (Orleans) 1.8 GHz
Memory: 1.5 Gb
Graphics: ATI RADEON 9600 128 Mb
Monitor: SyncMaster 940BW

I'm guessing I need to replace my graphics card and/or CPU, but if so, I'm not sure what to replace them with that will not require me to replace the other hardware that I have.

share|improve this question

5 Answers 5

up vote 2 down vote accepted

I think that both video and CPU components in your case are bottlenecks, but first of all look at the performance monitor - what CPU usage is during playback. Try to change CPU to Athlon 64 X2 4000 or faster. Such CPU are cheap and easier to find than modern AGP videocards.

share|improve this answer

You can also try CoreCodec's CoreAVC codec. It is supposed to work well on older computers. However, it is not free - but you can use their 14-day trial to see if it would solve your problem. In that case, do not use VLC. You won't see any difference, because VLC has it's codecs compiled and won't use outside decoders. I recommend MPC-HC

share|improve this answer
    
Will try CoreAVC as well. I already have MPC-HC. –  sjlewis Oct 18 '10 at 6:18

Have you tried playing the videos on other computers (more powerful/recent computers if you have access to them)? Could just be badly rendered/corrupted MKV's. Try installing Shark007 Codec Pack and see if the videos play properly (in Windows Media Player, as VLC uses its own codecs)

If it plays on other computers fine then it's probably your hardware that needs an upgrade. HD video playback is more dependent on CPU than GFX. In your case this is good since you'll get more bang for your buck (performance/cost) upgrading the CPU than buying a new AGP graphics card anyway. Your best bet would be to upgrade to a processor in the Athlon 64 X2 family, as this will fit straight into your current motherboard and you won't have to upgrade other parts of your computer.

share|improve this answer
    
The videos played fine on my work PC. Will try Shark007 at home, then do a performance monitor during playback to check. Will also consider buying an Athlon 64 X2. –  sjlewis Oct 18 '10 at 6:13

A modern graphics card with up to date drivers can decode and play full 720p video without any real cpu processing power required.

My nVidia GTS240 (9800 equivalent, so the internet tells me) can fully decode 1080p video and leave my CPU running at 1-2% usage.

Do not use VLC as I do not think that it supports using the graphics card to decode HD video, it didn't last time I tried it. If you get the latest Divx package then it can enable Windows Media Player to handle .mkv files (which are quite common for HD video) and Windows Media Player can use DXVA to use the graphics card to decode the video. To be honest, I quite like the Windows Media Player, it's gotten a lot of polish since the XP and Vista days...

As a side note you can use GPU-Z to tell if your graphics card is doing the decoding, at least it does on my nVidia. In that program, on the "Sensors" tab, there is a "Video Engine Load" which gives an indication of how difficult the file is for the card. For 720p it seems to hang around the 7-15% area, for 1080p it goes up to 35-50% usage.

I would recommend you get a new graphics card, either a GT240 or better.

EDIT

As it was pointed out that the system was AGP (which I should've checked to be honest) there is a good likelihood that an up to date ATi might work as well as it seems that nVidia have completely abandoned AGP. I had a Radeon 3870 that worked quite well with 720p and "standard" 1080 content but failed with "high profile" 1080 video, newer cards and newer drivers would probably work better than what I experienced.

Maybe GIGABYTE GV-R465D2-1GI Radeon HD 4650 1GB 128-bit GDDR2 AGP 8X HDCP Ready Video Card or HIS IceQ H467QS1GHA Radeon HD 4670 1GB 128-bit DDR3 AGP 4X/8X HDCP Ready Video Card would work

share|improve this answer
    
GT240 and pretty much all the recent video cards that support hardware decoding need a PCI-E slot, which would mean the OP would need a new motherboard (his only has AGP), and thus a new CPU and possibly RAM on top of a new graphics card. –  evol Oct 17 '10 at 12:58
    
Okay then, an up to date ATi might work just as well, such as newegg.com/Product/…-14-1‌​02-851--Product but I had some trouble with ATi and hardware decoding whereas nVidia "just worked" –  Mokubai Oct 17 '10 at 14:26

Hardware video decoding is often not used by default. Check to see if your video adapter supports hardware video decoding, then set it up to do so. The best guide on this seems to be here: Watching H.264 videos using DirectX Video Acceleration (DXVA)

I finally got the settings right, and my X301 laptop from two years ago (Intel Core 2 Duo SU9400 1.4 GHz + integrated GMA 4500MHD video adapter) can drive a 1920x1080p H.264 video perfectly with only 20-30% CPU load. Without the right settings, the videos were being decoded in software with 99% CPU load and a lot of videos had artifacts or just failed to play.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.