Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just upgraded to Ubuntu 10.04 Lucid, and mythtv now has an audio/video sync issue. Specifically, the audio is consistently about half a second ahead of the video. This is a playback issue, rather than recording, because it occurs on old recordings that were previously fine, as well as on Live TV and on recordings made since the upgrade. In the in-playback menu (press M) there is an option to adjust the audio/video sync, and adjusting it 500ms to the right solves the problem, but this setting does not persist.

How can I either make that setting persist or correct the root cause of this desynchronisation?

MythTV version: 0.23.0+fixes24158-0ubuntu2

Audio output: ALSA:default

PulseAudio is running and shows mythtv as a client, but setting audio output to ALSA:plughw:0 does not help and, in fact, seems to cause video to play at about half speed and keep abruptly catching up to real time.

I've tried toggling the options "Extra audio buffering", "Agressive audio buffering", "Use OpenGL VSync for timing", "Upmix audio to 5.1" all with no effect.

...and I don't want to downgrade MythTV. :-) (database schema has changed and there might not even be a downward migration script)

share|improve this question

If you're still having problems with this, it might be worth trying the OSS drivers for audio.

share|improve this answer
Aren't they unmaintained now? Also, I need to run other apps on that box that don't speak OSS. – Chris Boyle Nov 22 '10 at 0:32

I've had the same problem. The solution was to set in frontend: "Advanced Audio Configuration" --> checked and then "Override SRC quality Sample Rate Conversion" --> Disabled

share|improve this answer
Thanks, but that too doesn't seem to have any effect. – Chris Boyle Nov 22 '10 at 0:25

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.