Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
Disable Mac startup sound

I tried to disable startup sound by pressing mute button during boot. Then I tried also StartupSound.prefPane application mentioned on several sites ( but nothing works for me. The startup sound is always there without any change.

My iMac is new... bought in October 2010 and of course powered by Intel.

share|improve this question

marked as duplicate by Chealion, BinaryMisfit Oct 23 '10 at 7:00

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

up vote 1 down vote accepted

You can disable the startup chime with shell scripts: ( Tested on 2008 MacBook w/ 10.6.4 )

Create a shell script named in directory of preference. In this example the script resides in /Users/youraccount/Desktop :

sudo emacs

Enter this code in the script:

osascript -e 'set volume with output muted'

Make the script executable by root :

sudo chmod 755

Enter this code in Terminal :

sudo defaults write LogoutHook /Users/youraccount/Desktop/
sudo defaults write LoginHook /Users/youraccount/Desktop/

You may not need to have both hooks, but it definitely works when both are created. Your startup chime should be muted on reboot. The caveat is that you have to unmute your volume each time you login...

share|improve this answer

Disabling the POST is a bad idea. The Power On Self-Test is there to let you know if any serious hardware issues are detected once the machine begins to boot. However, the methods you have already tried are correct. It is possible that Apple has made modifications so that you can no longer hold down the mute key to disable the POST sound and I haven't been able to find a date that shows when the StartupSound preference pane has been updated. It could be that your iMac is too new for it to work.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.