Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
Disable Mac startup sound

I tried to disable startup sound by pressing mute button during boot. Then I tried also StartupSound.prefPane application mentioned on several sites (http://www5e.biglobe.ne.jp/~arcana/software.en.html) but nothing works for me. The startup sound is always there without any change.

My iMac is new... bought in October 2010 and of course powered by Intel.

share|improve this question

marked as duplicate by Chealion, Diago Oct 23 '10 at 7:00

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

2 Answers

up vote 1 down vote accepted

You can disable the startup chime with shell scripts: ( Tested on 2008 MacBook w/ 10.6.4 )

Create a shell script named off.sh in directory of preference. In this example the script resides in /Users/youraccount/Desktop :

sudo emacs off.sh

Enter this code in the script:

#!/bin/bash                                                                     
osascript -e 'set volume with output muted'

Make the script executable by root :

sudo chmod 755 off.sh

Enter this code in Terminal :

sudo defaults write com.apple.loginwindow LogoutHook /Users/youraccount/Desktop/off.sh
sudo defaults write com.apple.loginwindow LoginHook /Users/youraccount/Desktop/off.sh

You may not need to have both hooks, but it definitely works when both are created. Your startup chime should be muted on reboot. The caveat is that you have to unmute your volume each time you login...

share|improve this answer
add comment

Disabling the POST is a bad idea. The Power On Self-Test is there to let you know if any serious hardware issues are detected once the machine begins to boot. However, the methods you have already tried are correct. It is possible that Apple has made modifications so that you can no longer hold down the mute key to disable the POST sound and I haven't been able to find a date that shows when the StartupSound preference pane has been updated. It could be that your iMac is too new for it to work.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.