Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have windows and linux distros on my /dev/sda.

I tried to install fedora 13, but after reboot I cannot boot up to any of installed systems. I'm getting:

Non-System disk or disk error

replace and striky any key when ready

When I use ubuntu 10, boot from first hard disk, I'm able to get GNU GRUB version 1.98... and boot up to any system. but without ubuntu in a cd-rom I'm getting this error.

I tried: grub-install /dev/sdX in one of my installed linux distros, but without any success.

I really don't know what to do. Thank you very much for any help.

share|improve this question
add comment

migrated from serverfault.com Oct 17 '10 at 17:19

This question came from our site for professional system and network administrators.

1 Answer

It sounds like your BIOS isn't set to look at your hard drive. Did you set it to boot from the cdrom for installation and forget to set it back?

share|improve this answer
    
I didn't have to change it, but I tried as well to modify order and set hard drive first or to pick it from menu. Unfortunately without success. –  feiroox Oct 17 '10 at 18:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.