Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I had a WinXP installation on my hard drive. Then I bought a 2nd drive and installed Win7. Dual boot working fine. But when I'm in the Win7 environment, it appears that I don't have full admin permission on the "D" drive (that's the drive with WinXP). Even though the user I'm logged in as has admin permissions, I have to run my apps with administrator privileges in order to get write access to the D drive. This is not the case when I do stuff on the C drive.

I could just get into running those apps that access the D drive in admin mode, but that seems like overkill. Is there some secret switch I can flip so that my D drive acts like my C drive, security-wise?

share|improve this question

Your Win7 user is probably just not added to the WinXP disk's ACLs. (I assume each OS has it's own users, and is not attached to an outside domain).
Running with admin privs (in Win7), simply add your user to the ACL on D, and have it propagate to sub-folders and files.
Note that when you're back in XP, if you look at the ACLs, you'll see an ACE there for an unrecognized user, don't worry - its just that XP cannot resolve the SID to an actual user, since it doesnt really know about the Win7.

Not so secret... :)

share|improve this answer
Hey, @AviD, nice to see you here! Pardon my ignorance - I'm more a software guy than hardware - how exactly do you add a user to the ACL? If you're talking about right-clicking "Properties" on the D drive and selecting "Security" - my "Administrators" group (of which my user is a member) already has full access to the drive. Is there somewhere else to setup the ACL? – Shaul Behr Nov 14 '10 at 13:38
you too :). No, that's exactly what I was referring too (though you know thats NOT hardware, RIGHT? ;) ). The problem is that on Win7, unless you elevate to Admin, you're not IN the Administrators group! Therefore, try adding either your user directly, the Users group, or Interactive Users (or some other non-admin group) and make sure you have the correct rights, and that they propogate to the subfolders. – AviD Nov 14 '10 at 14:08
Curiouser and curiouser... I tried adding the user to "D" drive with full control rights, and it started going through the D drive, directory by directory, telling me "Access denied"! Something tells me I need to run the "Properties" box with admin rights! Any idea how to do that? – Shaul Behr Nov 14 '10 at 14:50
Yup, is as I said "Running with admin privs...". Point is, you're not really an admin at this point. If you rightclick Windows Explorer, you can select "Run as Administrator". Everything spawned from that is then started with the elevated token. – AviD Nov 14 '10 at 15:07
Nah, that still doesn't work... same behavior as if explorer was running as regular user... "Access denied" on everything. – Shaul Behr Nov 14 '10 at 17:19

You need to take ownership, i recommend you to do it with this command line tool microsoft provides Follow the instructions there and use this command to get full access and ownership

XCACLS.vbs z:\ /g user:f /T

Replace z with your hard drive's letter and user with your user name

share|improve this answer
From the page you linked: "Xcacls.vbs is only compatible with Microsoft Windows 2000, with Microsoft Windows XP, and with Microsoft Windows Server 2003. Xcacls.vbs is not supported by Microsoft." I'm using Windows 7... – Shaul Behr Feb 1 '11 at 17:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .