Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

There is quite some posts about this, but I can't find my exact situation...

We have a small office network, which gets its internet through a 3com officeconnect 8 3C16794. On this switch are another 3com switch going to 5 computers, which are not relevant for the question, a printer and then we have to connect 7 computers to the remaining 6 ports. So on one of those ports I have a level one FBR-1418X router for two pc's. The cable goes into the wan port of the router.

These 7 pc's are in the same workgroup, but computers on the router cannot find the others and the other way round.

The switch dispatches ip adresses in 10.10.10.X range and the router in the 198.168.123.X range with the same subnet of 255.255.255.0.

I have come so far that now I can ping computers in the 10.10.10.x range from the two on the router. The other way round does not work. Non of the computers "find" computers on the other lan. (in windows look for computers in the workgroup) They find all computers on the same lan in both cases.

The router has a setting for ip table, but I don't know if putting anything there will be of any help, and of the officeConnect switch we don't find the password to log into it's web interface...

Rebooting does not resolve...

Any hints greately appreciated

Update: On further thought, it would seem logical that if I could add the ip adress range of the router to the routing table of the switch then all computers should be able to find eachother, and that might resolve the issue... The problem is the default 3com passwords I find on the net don't work for logging into the switch and obviously nobody here has a clue of the password. So if anyone knows the default password for this model, might help. Does this make sense?

share|improve this question
    
"switch dispatches ip address.." my understanding is that switches do not "dispatch" (assign) ip addresses. Are you sure that you don't have two routers setup, thus cuasing connection issues? –  KronoS Oct 18 '10 at 16:24
    
Why don't you arrange for everybody to be on the same segment? –  harrymc Oct 18 '10 at 16:29
    
I did a check and between the switch and the modem there is indeed another device called Cisco Soho 71. Possibly that is giving the ip addresses. –  ufotds Oct 18 '10 at 16:33

2 Answers 2

up vote 1 down vote accepted

First thoughts: Putting anything into the IP table of the router will not help; your problem is in the other direction. Your computers are in separate subnets, and not enough IP address translation is going on. Actually, none should need to be; there's no call for a separate subnet here - quite the opposite, you want everything on the same subnet.

For a really quick fix to try: Stick the cable to the 3com switch in one of the other LAN ports of the FBR-1418X, not the WAN, as if the 3com was another PC. If you have to use this kind of router as just a switch, that's how to do it. By using the WAN port you're telling it to act as a router and run a local network - it's performing DHCP and assigning local addresses itself, which is really not what you want.

Summary: A router is overkill for getting four computers into two LAN ports; a switch is the correct solution. Daisy-chaining switches is much less error-prone than daisy-chaining routers. (Of course most modern routers are switches, but your problem is that yours is acting as a router, not just a switch. )

(Also: A lot of OfficeConnects have the default password 'admin', so try that - if you don't know that there's been another password set. Also try 'password' or 'manager'.)

share|improve this answer
    
ok, I tried that before and it didn't work, but now rebooted and reset the router and now it all works. Thanks alot, both of you who knew the answer. –  ufotds Oct 18 '10 at 16:54

Ok - getting confused by a few things (it's me, not you (headache!)! If I miss anything, please say and I will re-read thoroughly)

The router is simply being used to add additional ports, but it is also acting as a full router - providing NAT, DHCP etc.

If the router has 3 or more standard ports, the easiest thing you can do is disable DHCP and then plug the two computers plus the uplink to the existing switch straight in to regular sockets.

This will allow all computers to communicate just fine and they will appear to be on the same network.

When you start using the WAN socket, you are basically using NAT to bridge the two networks together - you can use firewall / incoming rules to help, but it can just be a nightmare... You can always disable NAT, but what I wrote above is by far the easiest solution.

Only negative is, remember to change the router's IP to something on the existing range or you will have to reset or manually change a machine address to be in its range in order to connect.... But once it is set, you shouldn't need to connect.

Lastly, I would like to say that obviously, if you are doing anything data/network intensive you may want to upgrade your infrastructure as this link will obviously be a weak point in the network.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.