Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm looking for a way to print multiple PDF files directly from within Finder. I have a duplex printer (HP Color LaserJet CP2025) and I want to use duplex printing as default.

Any suggestions?

Here is what I have tried so far. First I used this tip:

Try this: Open the "Print & Fax" panel of System Preferences. Drag the printer's icon from the list on the left onto your Desktop. The result will be an icon that is an alias for the printer. Now try dragging several documents onto that icon.

This partly works. Now I can select multiple pdf files and drag them to the printer icon in the Finder toolbar to print them all. However they are printed without using the duplex unit.

I figured the problem was that the wrong set of default settings were used, so I have tried to print from Preview using the duplex setting in order to set it as default. I have also set duplex to on the printer it self. Alas, this didn't help.

share|improve this question

3 Answers 3

I have found a workaround, but I wouldn't call it a proper solution.

  1. Start terminal and use lpoptions to make sure lpr is using both duplex and the proper tray:

    lpoptions -o Duplex=DuplexTumble
    lpoptions -o InputSlot=Tray2
  2. Start Automator and create a new application. Add the "Run Shell Script" action. Enter this script

    lpr "$@"

    and make sure the "Pass Input:" is set to "as arguments".

  3. Save the application somwhere.
  4. In the Finder drag the application to the Finder toolbar.
  5. Now pdf documents can be printed by dragging them on top of the application icon.
share|improve this answer
Duplex=DuplexTumble causes binding on the short edge, which is not what most poeple want. – vy32 Mar 8 '14 at 16:49

lpoptions may not actually do what you want in this case. If it doesn't work, try using lpadmin instead:

(example is for a Konica Minolta bizhub, forcing simplex)

lpadmin -p <printername> -o "KMDuplex=Single"

I had to use lpadmin to get the setting to stick and be reflected in the printing GUI.

share|improve this answer

Try clicking on the alias you made and setting Duplexing up in there.

share|improve this answer
Clicking the Alias brings up the corresponding print queue. Clicking the "Printer Setup" icon in the queue window brings up a window with 3 subpages "General", "Driver" and "Supply Levels". There are no settings I can change in any of the subpages. – Jens Axel Søgaard Oct 18 '10 at 18:35
Following the directions you posted and using one of our duplex printers I see the option under Driver, and it's settable. Is the setting there, just not able to be set? – eric.s Oct 19 '10 at 12:26
Hi Eric. Thanks for checking your printer settings. The interesting part is that I have no settings at all. Here are screen shots showing the tabs of the "Printer Setup" dialog. Should there be a list of settings present (The printer is an HP Laser Printer). – Jens Axel Søgaard Oct 20 '10 at 10:21
I see you found a workaround, but do you even see the duplexing option in the System Pref/Print Fax pane? I didn't see them trying to install the model you screenshotted. – eric.s Oct 20 '10 at 15:50
No, I can't see them anywhere in the system preferences. But if I open a document in, say, Preview, and choose "Print", then I do get the a choice whether to duplex print or not. I have found out that the workaround isn't working 100% though. Some pdfs (scans from a Xerox machine) is not printed properly. Is it an HP Printer you have? Do you see settings in the "Printer Setup" dialogue? – Jens Axel Søgaard Oct 20 '10 at 15:56

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.