Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I noticed strange occasional slowness in some games, and when I checked in Process Explorer, whenever my FPS drops in StarCraft or WoW, CPU usage was at 100%. Then I checked which processes were causing high CPU load, and it turned out that it was audiodg.exe (which was started by one of svchost.exe). I googled around and found this article (and some more which basically suggested the same) -- http://technicallyeasy.net/2009/03/fix-audiodgexe-high-cpu-usage/

I did what it told me to do (disable enhancements for playback devices), however problem wasn't solved by that: I still have occasional spikes of audiodg.exe's CPU usage. Does anyone know what other solutions might be for that?

I am using Windows 7, and my audio is onboard VIA HD Audio (my motherboard is M2N CM DVI and my audiodriver's version is 6.0.1.7400)

share|improve this question
    
Did you look for an Audio driver update? –  Moab Oct 19 '10 at 1:11
    
Seems like my system is broken, I can't delete or update the drivers –  LXj Oct 19 '10 at 11:59
    
I reinstalled Windows, installed audio driver version 8700, disabled enhancements -- but I still have this problem –  LXj Oct 27 '10 at 8:29

2 Answers 2

up vote 4 down vote accepted

There's a Hotfix from Microsoft which hits this nail exactly on the head:

A memory leak issue occurs in the Audiodg.exe process when you play audio on a computer that is running Windows 7 (and Windows Server 2008 R2, Windows Vista or Windows Server 2008)

From that link you can ask Microsoft to send you the Hotfix, and when you've applied it you won't then need to stop your audiodg.exe Service or throttle back any other audio features.

My system is Windows 7 x64 + 8GB RAM on an ASUS P7P55D EVO Motherboard with an i7 CPU and on-board VIA "High Definition" Audio + ATI Radeon HD 4350 Graphics Card.

While I was developing a C++ program I was sometimes generating dozens of successive short audio beeps which caused the audiodg process to 'hog' as much as 500MB of RAM! Plus, there was a lingering hike in CPU cycles for many minutes afterwards ... even though I'd stopped generating the beeps.

As expected; this Hotfix cured that audiodg bad behaviour.

share|improve this answer
    
I actually don't have this problem since upgrading, but you gave a good answer, so it seems appropriate to mark it. Thanks for your time! –  LXj Mar 7 '12 at 14:37

I had this problem too. For me me I think it was the Realtek monitor telling me I've plugged/unplugged an audio device.

Since my speakers are slightly damaged I can expect this. So I turned the Realtek HD program off at startup. I also have stopped the Audiodg.exe service from running and have had no further issues. No spikes and no drops since.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.