Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been running Ubuntu (10.04.1 LTS, 64-bit) for a while and just replaced my hardware with a faster machine with an ATI Radeon HD 5700 video card. I've got twin 1920 x 1080 displays. I downloaded the latest driver (ati-driver-installer-10-9-x86.x86_64.run) from the ATI web site and installed that.

I've gone through a few rounds of playing with /etc/X11/xorg.conf, and can't get things right. At the moment, it's in display mirroring mode, and I can't figure out how to get it out of mirror mode. If I run Monitor Preferences, there's a "Same image in all monitors" checkbox. If I uncheck that, the little preview window switches to show two monitors. When I click Apply, it asks me to log out and log back in again. When I do that, I'm right back to mirrored mode.

What's really weird is that I'm currently running a copy of xorg.conf from a coworker's machine. He's got identical hardware, and his display works fine. So, I'm inclined to think there's something else going on other than the conf file.

Any ideas what might be wrong?

share|improve this question

migrated from serverfault.com Oct 18 '10 at 23:11

This question came from our site for professional system and network administrators.

    
first, you should first tried installing drivers from repo, second, try amdcccle, third: question would be much better at superuser.com –  Hubert Kario Oct 18 '10 at 21:18
    
Are you running "Monitor Preferences" as root? –  Tog Oct 29 '10 at 12:12

1 Answer 1

Backup your config. Then try making a new one using aticonfig

aticonfig --initial=dual-head --desktop-setup=horizontal --screen-layout=left --xinerama=on

Test that out and compare the two to see what you want to add to your old config.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.