Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

because i was told it was a Windows problem, i wiped the hard drive and have a fresh Windows XP SP3 install. because the computer tech was able to install SP2 and SP3 using IE at their shop, it led me to suspect Firefox when the computer was installed at home using Firefox as my browser.

previous to the reinstall, my commit charge would become exceedingly high AND Firefox crashed every day.

I have a 160 GB hard drive with 70% free and 2GB of RAM.

at this very moment, i am using chrome BUT i am a huge fan of Firefox and would prefer to use it.

any ideas?

share|improve this question

4 Answers 4

Go to C:\Users\"USERNAME"\AppData\Roaming\Mozilla\Firefox\Profiles

Copy the folder that's in there, it should be random characters. After copying it to a different location. Make sure it's deleted.

Start up Firefox again. If the problem happens again then try and make sure you have the latest version of Firefox installed. If it still happens then it isn't firefox.

share|improve this answer

Firefox itself shouldn't reboot the system, but in conjunction with a bad plugin or a problematic video driver it can happen. The reboot never occurs outside Firefox (FF)?

I recommend running Firefox in safe mode to isolate the problem: if it stops occurring, it's most likely a plugin issue. The most trouble I've had was with flash but it seems to have stabilized - I'm running 10.1.85.x. Java can also cause issues... again try to isolate the issue by disabling plugins and using FF.

You didn't mention which version of FF you are using?

share|improve this answer
    
or disable all of the addons, and introduce them one at a time, in order of most important to you... –  studiohack Dec 1 '10 at 3:38

Looks like the RAM? I would test the RAM with MemTest

share|improve this answer

Run a spyware/adware scan with some free programs like adaware,avg,avast etc and see if anything pops up. Also try running FF on safemode and see if it makes a difference.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.