Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have just deleted 3 folders from a directory. 2 of the folders have been deleted and gone, the third remains. The delete completed successfully. I used shift-delete to avoid the recycle bin. Clicking on the folder gives 'Access is denied'. Programmatic tests show the folder "does not exist" but can't be created either.

This is on Windows XP 64-bit.

Does anyone know why this happens and how I can fix it? Will try a reboot but even if that works still interested in the underlying reason.

share|improve this question
    
Which directory are you trying to delete from? –  ChrisF Oct 20 '10 at 11:06
    
64-bit XP is a very different beast than 32-bit XP, it's got more in common with Vista than with normal XP. As such it does have a number of system folders that the user has no access permissions to, and aren't actually real folders (placemarkers, junction points, links and the like) are you trying to delete one of those? –  GAThrawn Oct 20 '10 at 12:36
    
@ChrisF/GAThrawn - just one of my own directories. There is nothing special about the parent or the target directory, there are not system directories. –  Mike Q Oct 20 '10 at 13:03
    
"Programmatic tests show the folder "does not exist" " It could be a file system error, chkdsk would fix this. –  Moab Oct 20 '10 at 15:47

3 Answers 3

As @Krazy_Kaos was saying, most likely a process has the directory or file open. I use Process Explorer from Sysinternals to fix this issue. Use the search feature of process explorer and search for the file or directory that isn't about to be deleted, it will return the process and handle that is using it, then use process explorer to kill the handle or process.

share|improve this answer

If this is not a program that is blocking the deletion, check the Security tab in the directory properties to view if you have the rights on the directory.

share|improve this answer

On my long gone days with Windows I ran into the same problem, the solution I found was one of these programs:

  • Unlocker - It usually solved the problem , if the problem was that the file was locked by some process:

alt text

But if even that wouldn't solve it, I would use:

  • MoveOnBoot - With this program, I could move, or delete the file on the next boot
share|improve this answer
    
Unlocker will offer to schedule a move/delete/rename on startup, if it fails to unlock the file. –  Bob Jun 12 '12 at 6:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.