Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having trouble doing a find and replace in Word 2007.

I have a document with a load of French quotes which should be followed by non-breakable spaces, but are currently followed by normal spaces.

Rather than going through by hand, I want to do a find and replace of "« " with «nbsp; (or whatever the Word equivalent is).

The Find works fine, but the « gets replaced as ".

Any ideas? Everything that Google throws up is about SmartQuotes, which isn't my problem.

share|improve this question
add comment

1 Answer

up vote 4 down vote accepted

Actually you have to uncheck the autocorrect quotes box in the Autocorrect tab (using MS Office 2010 in italian: it should be under Options > Correction Options > Autocorrect Options; in previous versions I don't know, in 2003 and before it should be under the Options menu). After unchecking:

In the document copy once the « symbol. In the Replace tab paste the « symbol in both find and replace spaces and in the find space add a space while in the replace line add a non-breakable space (by holding down shift and ctrl while pressing space). Replace All

share|improve this answer
    
Thanks! I was worried I was going to have to write myself a macro. –  Benjol Oct 21 '10 at 5:45
    
I'd upvote this again if I could! –  Benjol Nov 15 '10 at 11:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.