Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

While trying to open/access OpenOffice documents on Windows 2003 server it gives a very slow response, while accessing the same document using Microsoft Office 2007 it opens up instantly.

The version of OpenOffice installed on Windows 2003 server is 3.2. I have even tried saving the document in OpenDocument format (.odf) itself, but even then it is slow.

This happens generally when opening the documents with OpenOffice Calc.

Is there any settings that an be tweaked to make it open up faster?

share|improve this question
    
I have posted the same on serverfault hence I am deleting this. –  user44212 Oct 29 '10 at 13:35
    
Open office is just slow to start. I think it's an architecture thing (Java vs Native Code). –  Fake Name Dec 11 '10 at 13:04
    
I assume this is a terminal server? –  Bryan Dec 11 '10 at 14:00
    
Yes it is a Terminal server. –  user44212 Dec 16 '10 at 12:58

3 Answers 3

One of the option is go to tools > options > Click on Memory. Decrease the number of objects in cache for inserted objects.

share|improve this answer

MS Office is started at boot time, so it is already loaded and running, even if you are not using it. That is why it appears to start instantly. Open Office on the other hand, only uses system resources when you are using it, but the tradeoff is that you need to give it a chance to start up.

Once Open Office is open on one document, does it take a long time to open another one, or is it as quick as MS Office?

share|improve this answer
    
I did try removing the same from the startup but the behaviour is the same. As checked on the task manager there is a process soffice.bin which cnsumes lot of memory. –  user44212 Nov 29 '10 at 11:50

Do you have Java Runtime Environment installed in your Windows 2003 Server machine? If not, install it and then enter Open Office settings (start > execute > soffice > tools > options) and in Java section point to Java installation.

Try also to see if some optimized server settings, like some related services that would be disabled, are affecting OpenOffice performance or if in Performance Settings (win+break > advanced > performance > settings > advanced) the use of the computer is optimized to programs or to backgound services/system cache). Change something and retry using OpenOffice.

share|improve this answer
    
To download JRE: java.com/inc/BrowserRedirect1.jsp?locale=en –  kokbira Jul 15 '11 at 18:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.