Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I can't write to my NFS (Xtreamer media player). Writing works fine via Terminal, but in Finder everything is read only and Finder says "Zero KB available." and gives me the error message "The item abc.rtf can't be copied because there isn't enough free space." when I try to copy files to the NFS. Creating folders works fine, but copying files to them does not work.

Any ideas?


share|improve this question

Just a guess, but NFS uses UIDs to determine permissions. Are you sure you're using the same UID to log in with both the terminal and the GUI? You can see what your UID is (in 10.5 or 10.6 only) by going to System Preferences > Accounts pane and Control-Clicking on the account to get the Advanced Options.

share|improve this answer
No, it doesn't work. I'm connecting using the same UID. – wanten Oct 26 '10 at 16:41

I don’t know if you still care about this problem, but I’m posting the solution here to be found by others experiencing this problem.

First, you need to get the Xtreamer Mod Pack

This will allow you to enable telnet access to the xtreamer. After you start the telnet server, telnet to the xtreamer and edit the smb config file at: /usr/local/daemon/samba/lib/smb.conf

Change the get quota command parameter under the [global] section to /usr/local/daemon/samba/sbin/my_get_quota.

Then you need to change the path variable of the [Xtreamer] section to point to you hard drive, and not to /tmp/usbmounts. In my case, I had to change it to /tmp/usbmounts/sda1

The last thing to do is to create the my_get_quota script:

print 0 0 0 0 0 0 0

Now restart the smb server by running:

killall smbd
/usr/local/daemon/samba/sbin/smbd -D

That’s it. Finder should now report the correct size and allow you to copy files.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.