Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a small(?) issue program. A friend of mine has a computer with the following specs:

  • Creative XtremeMusic soundcard (latest x-fi drivers, the complete package)
  • USB Midimate 2 (usb midi interface)
  • Yamaha CS1x keyboard with midi outs (connects to computer with MidiMate 2)
  • Program called Ableton Live 8.1 to record midi and playback midi

My problem is the following.

Creative delivers it's own ASIO drivers, but those aren't as good as the ASIO4ALL drivers. That's why ASIO4ALL is recommended. (the sound and the latency is much better)

When installing the ASIO4ALL drivers, you will get a option in Ableton to use them. The only problem is that MS GS WAVETABLE synth? occupies the output and that's the reason why you can't hear any sounds through the speakers. When enabling the Creative ASIO driver, the sounds are back.

GS MS Wavetable occuping synth

p.s. this is a pic from the internet, not one from the system, it's a other soundcard, but the same error message.

In forums there are a few solutions which worked for a few people, but also not working for many others.

Here is a small list of (might work) solutions (i tried all those)

1:Right click the volume icon in your system tray
2: click playback devices
3:right click speakers
4: click properties
5: click advanced
6: uncheck "allow applications to take eclusive control of this device"
7: uncheck "give exclusive mode applications priority"
8: open FL Studio 8(or any program for music that supports ASIO4ALL or ASSIO4ALL2)
9: click options
10: click audio settings
11: change device to ASIO4ALL or ASIO4ALL2
12: Click "Show asio panel"
13: click advanced
14: check "always resample 44.1kHz <-> 48 KHz"
15: MAKE MUSIC! :D

The only thing I couldn't try yet was the one I found writing this question.

  • Control Panel -> Sounds/Audio -> Audio tab -> volume button in "Midi playback"--MUTE SW SYNTH

The solution above sounds logical, because I didn't connect the midi synthesizer with the midi port (gameport) of the X-fi soundcard but with a USB interface of the midimate 2

Could this solve it? or does anyone have other options?

Fix: Just indeed disable de midi synth as described above, and turn off systemsounds.

share|improve this question
add comment

1 Answer

I believe you cannot mix a DSP based digital mixer with an Analog Windows mixer. The Windows mixer which includes your Vinyl Audio and Midi wavetable cannot mix with USB headphones nor X-FI sound card. Both are Digital audio sources.

ASIO4ALL allows one to create connections in analog sound from port to port that are analog only.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.