Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I view my user folder C:\Users\myname, I get icons with no filenames similar to what is shown here

I use my user folder often for files that are not organized yet and I also have custom folders that are not Documents or Videos or Music or Pictures. I often set to hidden the folders I don't use like Contacts and Searches and Games.

When I go to my user folder from the start menu, I right click the background and click "Customize This Folder" I get a dialog error with the title "Desktop" (weird) and the text "The properties for this item are not available".

Now navigating directly to C:\Users\myname instead of using the start menu looks just fine. It only looks bad when clicking from the Start Menu

Does anybody know where the data is stored so I can clear it back to default or something? Or does someone know another way to get the file names back?

Edit: I am starting a bounty because I would really like to get my file names back. If anybody knows how to reset that data without using System Restore I would gladly assign the reward to them.

Edit: If I could temporarily use the Pictures and Videos template on my user folder (without using "Customize This Folder" then I think I can fix the problem.

Edit: I would expect the answer to be in the registry... somewhere

SOLUTION!!!

Many thanks to harrymc for the solution (one of the last comments in his answer). There is an .exe file and .reg file available to reset the Windows Explorer folder template information and also to prevent Windows from auto-selecting a default template with a silly notion that a single image file makes a pictures folder (and stuff like that): http://www.annoyances.org/exec/show/choosetemplate

share|improve this question

migrated from stackoverflow.com Oct 20 '10 at 22:29

This question came from our site for professional and enthusiast programmers.

    
I'm returning your bounty and moving this over to Super User where you should get an answer. –  Bill the Lizard Oct 20 '10 at 22:29
    
Thanks! I did not even think of the other websites! –  George Bailey Oct 20 '10 at 23:04

2 Answers 2

up vote 2 down vote accepted
+50

See this article: How to Hide or Show File Names in Vista.

Navigating directly to C:\Users\myname, execute the instructions in the article for options 2 and 3 (although your article already contains option 3). When executing option 3, ensure that "Also apply this template to all subfolders" is checked.

This article might have a hint as regarding the problem:
Why can't I select the 'Customize this folder' option for folders such as the winnt and winnt\system32 folders?.

It seems like the 'Customize this folder' option is dictated by the file desktop.ini in the folder. This file is hidden for sensitive system folders, but it is still there. It is probably this file that is corrupted for "C:\Users\myname".

The workaround suggested in the article is to create a new folder and set it to the required customization, then copy the desktop.ini file from the new folder to "C:\Users\myname" (better rename first the old one, just in case).

For example, here is a desktop.ini for "Pictures and Videos" :

[ViewState]
Mode=
Vid=
FolderType=Pictures
share|improve this answer
    
I already knew about option 2, but I really liked being able to use the large icons. Option 3 does not work for me because "Customize This Folder" is required. But if I could change the user folder to the pictures and videos template without using "Customize This Folder" I think I could fix the problem (assuming I can change it back) –  George Bailey Nov 1 '10 at 12:34
    
I added a possible workaround above. –  harrymc Nov 1 '10 at 13:11
    
The thing is, there was no old one. It turns out when I set the icon in Vista on a folder, desktop.ini is created.. But when I set the folder type (Documents, Pictures, Music) it does not happen. I looked at one of my old folders and the folder type was in Desktop.ini... that must have been from my XP machine (copied over) because changing the folder type and changing desktop.ini seem to be separate functions. –  George Bailey Nov 3 '10 at 12:31
    
I can see on Vista that desktop.ini does change when customizing the folder type - the "FolderType=" line changes accordingly. So I do advise to try copying desktop.ini from a Vista customized folder and see what happens. However, if you copied over this folder from XP to Vista, this could be the problem. I suggest renaming it, re-creating and customizing it, then copying over all included data. –  harrymc Nov 3 '10 at 12:56
    
I added it above, but hold everything! Just tried it on a Vista VM and it didn't work! The difference between it and my machine is apparently the Default Folder Template Patch from annoyances.org. See annoyances.org/exec/show/choosetemplate. –  harrymc Nov 3 '10 at 18:07

Go to any folder that looks like the way you want. Press "Alt Key", chosse "folder Options" under "tools" menu. Go to the tab in the middle, and click "Aply to all".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.