Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Yesterday, I made a macro to automate switching to a split view in the print layout. It worked fine, and I added a button for it to the quick access toolbar. All was good. Now, today, the button is still there, but when I click on it, I get this error message, "The macro cannot be found or has been disabled because of your Macro security settings." I have not changed the security settings. What happened? How can I get my macro back? I don't want to have to remake it every time I start Word; that kind of defeats the purpose. Thanks.

ADDITIONAL INFOMRATION

From Developer Tab -> Code group -> Macros button, I cannot find the micro anywhere in the dialog box that appears. I looked through all the options in the "Macros in" drop-down. Did the macro not get saved?

ADDITIONAL INFOMRATION

I just tried to remake the macro. In the Record Macro window I gave it the name PageLayoutSplitView and left the "Store macro in" at the default setting of "All Documents (Normal.dotm)." Again, it worked fine until I restarted Word. Then the same problem as before.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Looking through Word 2007 it looks like any macros that you want to be globally available need to be stored in "All Documents (Normal.dotm)". When you created the original file where did you save it?

Using the Visual Basic Editor (ALT+F11) you can verify whether or not the macro is saved in your Normal file. Referencing the example image below you can see any macros, in any open documents, by opening any Modules attached to the them.

VBE

share|improve this answer

Click the Microsoft Office Button, and then click Word Options. Click Trust Center, click Trust Center Settings, and then click Macro Settings. If not changed, the default setting is "Disable all macros with notification". Make sure that it's selected. This way, you can choose when to enable macros on a case by case basis. Restart Word, and check if it gives the notification whether you want to disable or enable macros. Then select "enable".

share|improve this answer
    
Yes, that option is already selected. Please see the additional information I posted. Thanks. –  Jim Fell Oct 21 '10 at 15:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.