Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use Mac OS X Leopard with 4 different Spaces and an external monitor at workplace, which is located above the laptop. On each Space I work on a different project, with different terminal windows and Xcode and Finder windows. The problem happens when I am at home, then I use an external monitor but now located at left position. When the MacBook wakes up, everything gets messed up and even some windows switch from one space to another.

Could I somehow fix it so always the windows belonging to one Space remain there and also the association to main/external monitor even if I change to another external monitor?

Thanks

share|improve this question
    
Do you wake up the MacBook in "clam-shell" mode (external monitor/keyboard/mouse with lid closed)? –  harrymc Oct 30 '10 at 12:22
2  
There is no point in advertising a bounty if you don't answer questions. –  harrymc Oct 31 '10 at 8:48
    
no, I do not do that, as I want to use both main and external monitors –  flow Nov 1 '10 at 11:18
add comment

4 Answers

up vote 0 down vote accepted
+50

Do either of these work?

Or perhaps the best sounding one:

share|improve this answer
    
Last version of Forget me not is for Tiger. –  Daniel Beck Jan 13 '11 at 12:06
    
I've used Stay and it does what the questioner wants. –  user31752 Jan 13 '11 at 15:57
add comment

I don't know of an existing clean solution, but you ought to be able to hack it most of the way using some AppleScript like this one and/or some additional apps. Check out, for example, ReLaunch.

share|improve this answer
add comment

SwitchResX has an option that might help you with this, assuming the external screens have the same resolution.

enter image description here

share|improve this answer
add comment

I find I often get a similar problem whenever my screen resolution is changed in a dirty manner. Connecting an external display often does it, as do some older full screen applications, especially if they crash. I don't have an easy solution, but I do have a workaround - hide all applications save the Finder. Simply command-tab to the Finder, then select "Hide Others" from the "Finder" menu. Once you've connected your external display, you can bring the applications back by command-tabbing to them, or clicking on them on the dock.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.