Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

It seems that something's wrong with my weather gadget. It won't show the weather and it just says "Cannot connect to service." It's option and size buttons are gone and it's reverted to being small. It's been like this for about a week, and it's not like this on any other computer in my house or even on the other account.

I tried closing it, closing the sidebar, and reopening them; closing it, closing the sidebar, deleting it's folder in C:\Users\%USER%\AppData\Local\Microsoft\Windows Sidebar\Cache, reopening them, and uninstalling it and reinstalling it. Nothing seems to work. I tried restarting my computer too. Any ideas?

EDIT: It just downloaded the weather information for New York during the migration yesterday, and it's keeping it updated.(Maybe because I restarted it again?) That's the default for it, so that much makes sense, but I still can't change the options or make it the full size. :(

share|improve this question

2 Answers 2

up vote 2 down vote accepted

First, try Restore desktop gadgets installed with Windows:

  • Click Start

  • Type Restore gadgets into the Start menu search box

  • Click Restore desktop gadgets installed with Windows.

Is the issue still present?

If so, try another user profile. If another user account is not available, create a new user account by following these directions.

If the issue is still present?

Try performing a clean boot to determine whether a background application could be interfering with the gadget. Click here for the full instructions to perform a clean boot.

Reference: http://social.answers.microsoft.com/Forums/en/w7desktop/thread/46b13c44-5f7a-41a0-976c-e89732ce101c

share|improve this answer
The restore desktop gadgets is what I meant by uninstalling it and reinstalling it. I'll try a different account and see, though. –  Ullallulloo Oct 22 '10 at 2:07
I wonder if the weather service server it depends on is temporarily down? –  Moab Oct 22 '10 at 4:29
Just checked, it works on the other account... –  Ullallulloo Oct 23 '10 at 14:47
@Ullallulloo - Did you also try the clean boot method from the problem account? If you still have the issue during a clean boot then the user profile is in some way corrupt and you might have to follow these instructions: windows.microsoft.com/en-US/Windows7/… –  ricbax Oct 24 '10 at 15:20
No, but it just fixed itself...thanks, anyway, those were good things that I hadn't thought of. –  Ullallulloo Oct 25 '10 at 21:16

O_o I think it just fixed itself...I don't think that I did anything, but it suddenly works perfectly again. I had just logged out, into another screen name, and back in, but I did that a couple days ago, and it didn't work then...idk, either way, it works fine.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.